Bug 97031 - ghostscript generates trailing blank page if input is from stdin. wastes paper.
Summary: ghostscript generates trailing blank page if input is from stdin. wastes paper.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: ghostscript   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-09 13:46 UTC by John Ellson
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 15:00:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of: "printconf-tui --Xexport" (2.86 KB, text/plain)
2003-06-10 18:05 UTC, John Ellson
no flags Details

Description John Ellson 2003-06-09 13:46:16 UTC
Description of problem:
ghostscript (as used in gv and lpr) generates trailing blank page if
input is from stdin.
If the input is from a file then the extra page is not generated.
Affects gv and lpr.

Version-Release number of selected component (if applicable):
ghostscript-7.07-2

How reproducible:
100%

Steps to Reproduce:
1. pick any .ps file (the summary.ps is just an example, selected because it is
only 4 pages long).
2. cat /usr/share/doc/nvi-m17n-1.79/docs/USD.doc/exref/summary.ps | lpr
3. lpr /usr/share/doc/nvi-m17n-1.79/docs/USD.doc/exref/summary.ps
    
Actual results:
The cat'd version (2.) has an extra blank page at the end.

Expected results:
No extra blank pages.  

Additional info:
Same result with:
 cat /usr/share/doc/nvi-m17n-1.79/docs/USD.doc/exref/summary.ps | gv -

Comment 1 Tim Waugh 2003-06-10 15:24:35 UTC
I strongly suspect this is dependent on the particular driver you are using. 
Please attach output of printconf-tui --Xexport.

Comment 2 John Ellson 2003-06-10 18:05:07 UTC
Created attachment 92319 [details]
output of: "printconf-tui --Xexport"

Comment 3 John Ellson 2003-06-10 18:06:12 UTC
How would that explain the same problem occurring with "gv -" ?

Comment 4 Tim Waugh 2003-06-11 08:59:46 UTC
For that queue, gs is not even invoked as far as I can tell.  Must be something
that the foomatic filter does to the PostScript before it gets sent to the printer.



Comment 5 Tim Waugh 2004-12-10 15:00:50 UTC
"cat ... | lpr" doesn't generate a blank page here in FC3.


Note You need to log in before you can comment on or make changes to this bug.