Bug 970404 - mingw64-openjpeg not in repo (with fix)
mingw64-openjpeg not in repo (with fix)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mingw-openjpeg (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Sandro Mani
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-03 20:38 EDT by Steve
Modified: 2013-06-04 09:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 09:18:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New spec file (4.60 KB, text/x-rpm-spec)
2013-06-03 20:38 EDT, Steve
no flags Details

  None (edit)
Description Steve 2013-06-03 20:38:23 EDT
Created attachment 756603 [details]
New spec file

mingw32-openjpeg is in the Fedora repo, but mingw64-openjpeg isn't.

Also, there seems to be something wrong with the repo version of mingw32-openjpeg -- I tried to build a MinGW version of ffmpeg with openjpeg support, and ffmpeg rejected it.  It accepted the rebuilt one.

Enclosed is a modified spec file that creates both versions of openjpeg for MinGW.
Comment 1 Sandro Mani 2013-06-04 04:01:10 EDT
mingw-openjpeg was a dead package until recently, but has been revived a month or so ago, with the revived package offering both mingw32 and mingw64 variants (while the old one was mingw32 only).
That said, mingw-openjpeg was pushed into f18 updates yesterday (was in updates-testing before), so it should become available after the next repo sync (probably already today). In the meantime, you can enable updates-testing, or grab the build from here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=421734

Please report back if this fixes your issue and close.
Comment 2 Steve 2013-06-04 09:18:58 EDT
mingw-ffmpeg builds with the repo versions of mingw{32,64}-openjpeg, so I'll close this.  Thanks for your help!

Note You need to log in before you can comment on or make changes to this bug.