Bug 970447 - nm-dbus-manager delaying shutdown after F19 installation
nm-dbus-manager delaying shutdown after F19 installation
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 00:45 EDT by Jens Petersen
Modified: 2015-01-07 23:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-07 23:42:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console screenshot (18.29 KB, image/png)
2013-06-17 06:19 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2013-06-04 00:45:50 EDT
Description of problem:
I will try to grab a screenshot after my next install but
it seems NM is unable to connect to dbus during shutdown
after installation with anaconda which delays the reboot
process by about 1 minute.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.8.1-4.git20130515.fc19

How reproducible:
100% I think

Steps to Reproduce:
1. install F19 (eg default net install)
2. click Reboot in anaconda at end of install
3. wait for shutdown and reboot

Actual results:
3. errors on vc4 about NM not able to connect to dbus or so.
Systems take about 1 min to shutdown before rebooting.

Expected results:
No long delay to reboot after install.

Additional info:
Only happens right after installation.
Comment 1 Jens Petersen 2013-06-04 00:46:43 EDT
Meant to add this has been happening for a little while now,
at least a couple of weeks I think (before and after F19 Beta).
Comment 2 Dan Williams 2013-06-04 12:13:27 EDT
This will get fixed for F20 where NM doesn't require the dbus daemon to be running when talking to root processes; this has been in NM git master for a couple months.  Unlikely to happen for F19 though.
Comment 5 Jens Petersen 2013-06-17 06:19:41 EDT
Created attachment 761991 [details]
console screenshot

I see thanks.

Just for completeness here is a screenshot of the shutdown errors.
Comment 6 Rostislav Krasny 2013-10-01 18:26:53 EDT
I got exactly the same problem as well. I also saw the error message about inability to connect to the dbus. But instead of waiting so long time I just pressed Ctrl-Alt-Del after 15 - 20 seconds and my system has rebooted.

Did it make my installation incomplete in some aspect? Should I reinstall it and wait until it reboot by itself? I'm asking because right after the installation I'm unable to installa Firefox 24 with following error message:

01:06:31 : YUM: Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-19-i386
01:06:31 : YUM: Importing GPG key 0xFB4B18E6:
01:06:31 : YUM:  Userid     : "Fedora (19) <fedora@fedoraproject.org>"
01:06:31 : YUM:  Fingerprint: ca81 b2c8 5e4f 4d4a 1a3f 7234 0747 7e65 fb4b 18e6
01:06:31 : YUM:  Package    : fedora-release-19-4.noarch (@updates)
01:06:31 : YUM:  From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-19-i386
01:06:31 : ERROR: Error in yum Transaction : Didn't install any keys

Is it related issue?

Note You need to log in before you can comment on or make changes to this bug.