Bug 970467 - Recent Fedora update(s) crashes xbmc (i updated june 1)
Recent Fedora update(s) crashes xbmc (i updated june 1)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 01:46 EDT by trippy
Modified: 2013-10-08 02:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 02:39:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
files generated by abrt and xbmc crash log (11.58 MB, application/gzip)
2013-06-04 01:46 EDT, trippy
no flags Details

  None (edit)
Description trippy 2013-06-04 01:46:00 EDT
Created attachment 756621 [details]
files generated by abrt and xbmc crash log

One of the recent Fedora 18 updates (from official Fedora repository) crashes xbmc. I updated Saturday June 1.

It causes a sigsegv 11 signal to be sent to /usr/lib64/xbmc/xbmc.bin.

This happens the moment xmbc is supposed to show video (clicking on the .mkv, .mpg, avi). Audio files plays fine. It does not matter what kind of video file. Clicking on one crashes it. Xbmc does show a preview frame in the small square in the bottom right part of xbmc screen. Totem player (for example) has no problem playing the same files. Xbmc comes from the rpmfusion repository.

Install Fedora 18 clean > add rpmfusion repo > install latest xbmc-12.2-1.fc18 package > it works now > disable rpmfusion repo > refresh sources list > check for updates and install them > now xbmc crashes
Comment 1 trippy 2013-06-04 01:51:08 EDT
Oh, it's not the new kernel. (3.9.4-200.fc18.x86_64)

After updating i booted in the old kernel (the one present after clean Fedora 18 install) and xbmc still crashes.
Comment 2 Bill Nottingham 2013-06-04 09:26:47 EDT
Backtrace from above attachment, for reference:

#23 0x0000000000000000 in ?? ()
#24 0x00007f9c0603fdb3 in nv50_emit_vtxattr.isra.5 () from /usr/lib64/dri/nouveau_dri.so
#25 0x00007f9c06040ea9 in nv50_vertex_arrays_validate () from /usr/lib64/dri/nouveau_dri.so
#26 0x00007f9c0603719f in nv50_state_validate () from /usr/lib64/dri/nouveau_dri.so
#27 0x00007f9c06040f70 in nv50_draw_vbo () from /usr/lib64/dri/nouveau_dri.so
#28 0x00007f9c05e56879 in st_draw_vbo () from /usr/lib64/dri/nouveau_dri.so
#29 0x00007f9c05e307da in vbo_exec_vtx_flush () from /usr/lib64/dri/nouveau_dri.so
#30 0x00007f9c05e21f5f in vbo_exec_FlushVertices_internal () from /usr/lib64/dri/nouveau_dri.so
#31 0x00007f9c05e2ddf6 in vbo_exec_FlushVertices () from /usr/lib64/dri/nouveau_dri.so
#32 0x00007f9c05de086e in use_shader_program () from /usr/lib64/dri/nouveau_dri.so
#33 0x00007f9c05de1389 in _mesa_use_program () from /usr/lib64/dri/nouveau_dri.so
#34 0x00000000009bfde3 in Shaders::CGLSLShaderProgram::Disable() ()
#35 0x0000000000b0c723 in CLinuxRendererGL::RenderSinglePass(int, int) ()
#36 0x0000000000b0f512 in CLinuxRendererGL::RenderUpdate(bool, unsigned int, unsigned int) ()
#37 0x0000000000b0598d in CXBMCRenderManager::PresentSingle(bool, unsigned int, unsigned int) ()
#38 0x0000000000b05cdc in CXBMCRenderManager::Render(bool, unsigned int, unsigned int) ()
#39 0x0000000000b069a8 in CXBMCRenderManager::Present() ()
#40 0x0000000000e6fd24 in CApplication::RenderNoPresent() ()
#41 0x0000000000e72357 in CApplication::Render() ()
#42 0x0000000000f02be1 in CXBApplicationEx::Run() ()
#43 0x0000000000f099d7 in XBMC_Run ()
#44 0x00000000006ea523 in main ()
Comment 3 trippy 2013-10-05 10:52:55 EDT
It seems this has been fixed. I recently thought i'd give it a try again and xbmc plays video again fine. Thanks a lot for however fixed it.
Comment 4 Ben Skeggs 2013-10-08 02:39:24 EDT
Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.