Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 970554 - segfault from invalid "device_add" of ivshmem
segfault from invalid "device_add" of ivshmem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 06:23 EDT by Paolo Bonzini
Modified: 2013-08-31 16:00 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 16:00:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2013-06-04 06:23:28 EDT
(qemu) device_add ivshmem
Must specify 'chardev' or 'shm' to ivshmem
Segmentation fault (core dumped)

(qemu) device_add ivshmem,chardev=stdio
Must specify 'chardev' or 'shm' to ivshmem
Segmentation fault (core dumped)

because the chardev must really be a Unix socket.
Comment 2 Min Deng 2013-06-05 22:14:46 EDT
Hi Paolo,
   QE tried the bug according to the following scenario.
   case1,it won't reproduce while chardev with socket backend with unix option.
   {"execute":"chardev-add","arguments":{"id":"channel4","backend":{"type":"socket","data":{"addr": {"type":"unix", "data": {"path": "/tmp/mm4"}}}}}}
   {"execute":"device_add","arguments":{"driver":"ivshmem","chardev":"channel4"}}
   case2,
   the issue will be reproduced while chardev with others backend,such as file,pty.
   Thanks,any issue please let me know.

Best regards,
Min
Comment 3 Min Deng 2013-06-05 22:44:20 EDT
  By the way,I've been told by QE feature owner of ivshmem that ivshmem isn't supported in rhel7.0,thanks.Any wrong please correct me.
Comment 6 Cole Robinson 2013-08-31 16:00:56 EDT
qemu 1.6 doesn't crash here either, though qemu does exit(1) on bad parameters.

Note You need to log in before you can comment on or make changes to this bug.