Bug 970603 - [rhevm-manage-domains] Failed connect RHEVM to LDAP server (Directory Service Server)
[rhevm-manage-domains] Failed connect RHEVM to LDAP server (Directory Service...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Yair Zaslavsky
vvyazmin@redhat.com
infra
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 08:48 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 14:15 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 09:06:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Log engine-manage-domains (1.54 KB, text/plain)
2013-06-04 08:48 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-06-04 08:48:44 EDT
Created attachment 756751 [details]
## Log engine-manage-domains

Description of problem: Failed connect RHEVM to LDAP server (Directory Service Server)

Version-Release number of selected component (if applicable):
RHEVM 3.2 - SF17.1 environment: 

RHEVM: rhevm-3.2.0-11.28.el6ev.noarch 
VDSM: vdsm-4.10.2-21.0.el6ev.x86_64 
LIBVIRT: libvirt-0.10.2-18.el6_4.5.x86_64 
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.3.x86_64 
SANLOCK: sanlock-2.6-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run following command: 
 rhevm-manage-domains -action=add -domain=qa.lab.tlv.redhat.com -user=vdcadmin -interactive -addPermissions -provider=ActiveDirectory
  
Actual results:
Failed connect RHEVM to LDAP server (Directory Service Server)

Error:  exception message: null (29)
Failure while testing domain qa.lab.tlv.redhat.com. Details: Kerberos error. Please check log for further details.

Expected results:
Successfully connect RHEVM to LDAP server

Relevant information:
After investigation with Yair Zaslavsky, same problem was found in upstream, and SI17.3
With Alon Bar-Lev tool “GSSAPITest utility” authentication to LDAP server was successfully

Impact on user:

Workaround:
not exist

Additional info:

/var/log/ovirt-engine/engine-manage-domains.log

2013-06-04 15:31:38,697 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomains] Creating kerberos configuration for domain(s): qa.lab.tlv.redhat.com
2013-06-04 15:31:38,719 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomains] Successfully created kerberos configuration for domain(s): qa.lab.tlv.redhat.com
2013-06-04 15:31:38,719 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomains] Testing kerberos configuration for domain: qa.lab.tlv.redhat.com
2013-06-04 15:31:38,891 ERROR [org.ovirt.engine.core.utils.kerberos.KerberosConfigCheck] Error:  exception message: null (29)
2013-06-04 15:31:38,893 ERROR [org.ovirt.engine.core.utils.kerberos.ManageDomains] Failure while testing domain qa.lab.tlv.redhat.com. Details: Kerberos error. Please check log for further details.

Note You need to log in before you can comment on or make changes to this bug.