Bug 970617 - Unable to delete errata via deletion changeset
Unable to delete errata via deletion changeset
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 09:10 EDT by Brad Buckingham
Modified: 2013-07-18 17:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:20:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Buckingham 2013-06-04 09:10:25 EDT
Description of problem:

It is not currently possible to delete an erratum using a deletion changeset.  This appears to be an regression with the migration to pulp v2.

Version-Release number of selected component (if applicable):
git master

How reproducible:
Always

Steps to Reproduce:
1. sync a repo that has errata and promote it to an env (e.g. dev)
2. create a deletion changeset in the environment
3. add an erratum to the changeset
4. apply the changeset

Actual results:
The erratum is not deleted from the environment.

Expected results:
The erratum should be deleted from the envirionment.

Additional info:
Comment 1 Brad Buckingham 2013-06-04 16:27:29 EDT
katello pull request: 

https://github.com/Katello/katello/pull/2425
Comment 3 Brad Buckingham 2013-06-06 17:58:42 EDT
Mass move to ON_QA
Comment 4 Hayk Hovsepyan 2013-06-12 08:30:28 EDT
Tested on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
foreman-1.1.10009-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
katello-configure-1.4.3-15.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
katello-glue-elasticsearch-1.4.2-12.el6sat.noarch
katello-1.4.2-12.el6sat.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
candlepin-cert-consumer-cfseserver5.usersys.redhat.com-1.0-1.noarch
signo-0.0.16-1.el6sat.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
Katello-Katello-Installation-Satellite6Latest-1.0-8.noarch
foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.1.1-1.el6sat.noarch
foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
katello-cli-1.4.2-7.el6sat.noarch
foreman-postgresql-1.1.10009-1.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
foreman-proxy-1.1.10003-1.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-common-1.4.2-12.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-glue-candlepin-1.4.2-12.el6sat.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
katello-all-1.4.2-12.el6sat.noarch
katello-agent-1.4.2-4.el6sat.noarch
foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
python-ldap-2.3.10-1.el6.x86_64
ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
signo-katello-0.0.16-1.el6sat.noarch
katello-glue-pulp-1.4.2-12.el6sat.noarch
katello-configure-foreman-1.4.3-15.el6sat.noarch
candlepin-0.8.9-1.el6_4.noarch
katello-foreman-all-1.4.2-12.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-47.noarch
foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch


The issue still exists and the steps to duplicate are the same as described in description.
And to check errata list in environment can be done by content search of CLI "errata list --org ... --environment ..."
Comment 5 Brad Buckingham 2013-06-12 09:10:52 EDT
There is a known issue with using the test zoo repos with errata testing.  It is an issue of the updateinfo.xml not including a valid epoch for packages, so pulp is not correctly treating the errata.

The following is  BZ that was created when we first noticed issues with errata: 
https://bugzilla.redhat.com/show_bug.cgi?id=958932

We'll need to get the test repos; however, in the meantime, may need to test using RHEL repos.
Comment 6 Hayk Hovsepyan 2013-06-13 10:24:53 EDT
I have reproduced the issue with RHEL repo as well.

It shows that deletion type changeset is applied successfully, but still in "Content Search" or in CLI "errata list" output it shows filtered errata in that environment.
Comment 7 Brad Buckingham 2013-06-13 11:50:22 EDT
Found an issue with the request used for the deletion.

Katello pull request:
https://github.com/Katello/katello/pull/2487
Comment 9 Brad Buckingham 2013-06-14 20:08:40 EDT
Mass move to ON_QA
Comment 10 Hayk Hovsepyan 2013-06-18 11:23:55 EDT
Verified on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
foreman-1.1.10011-1.noarch
openldap-2.4.23-31.el6.x86_64
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
katello-1.4.2-14.el6sat.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
candlepin-cert-consumer-cfseserver3.usersys.redhat.com-1.0-1.noarch
signo-0.0.18-1.el6sat.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
Katello-Katello-Installation-Satellite6Latest-1.0-8.noarch
foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.1.2-0.3.beta.el6sat.noarch
foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
katello-cli-1.4.2-7.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.2-2.el6sat.noarch
pulp-server-2.1.2-0.3.beta.el6sat.noarch
katello-configure-1.4.3-16.el6sat.noarch
pulp-selinux-2.1.2-0.3.beta.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
foreman-proxy-1.1.10003-1.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-common-1.4.2-14.el6sat.noarch
katello-glue-candlepin-1.4.2-14.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
katello-all-1.4.2-14.el6sat.noarch
katello-agent-1.4.2-4.el6sat.noarch
foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
foreman-postgresql-1.1.10011-1.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
signo-katello-0.0.18-1.el6sat.noarch
katello-glue-pulp-1.4.2-14.el6sat.noarch
katello-configure-foreman-1.4.3-16.el6sat.noarch
candlepin-0.8.9-1.el6_4.noarch
katello-foreman-all-1.4.2-14.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-49.noarch
foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

Now it removes RHEL errata from environment via deletion changeset.
Comment 11 Mike McCune 2013-07-18 17:20:10 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.