Bug 97062 - up2date gets errors installing errata for RHL 7.2 (s390) kv-38
Summary: up2date gets errors installing errata for RHL 7.2 (s390) kv-38
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: s390 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-09 20:04 UTC by Bill Goodrich
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-25 18:38:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Goodrich 2003-06-09 20:04:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Windows NT 5.0; U)

Description of problem:
My scenario:

- Rebuilt base system on new dasd pack.
- Downloaded rhn_register and up2date packages (4 of them ... for some reason they're not installed as part of default).
- Installed the non-gnome packages (2 out of 4 packages).
- tried running up2date -l  but it kept barking about rhn_register
- ran rhn_register
- checked RHN system on web:	https://rhn.redhat.com/network/systems/system_list/visible_to_user.pxt
- found 2 updsch systems.
- deleted old updsch system from RHN list (click on system name, and then click delete-system button/link at top of page).
- ran "up2date --show-all" and that seemed to work
- afterwards tried to run "up2date -l" and got same message about not having the gpg key and told to run the following:
	/usr/bin/gpg --import /usr/share/rhn/RPM-GPG-KEY
- ran the above command
- tried "up2date -l --nox" again and got:
	Getting headers for skipped packages...
	There was a fatal error communicating with the server.  The message was:
	404: "Not Found" while attempting to get
	$RHN/redhat-linux-s390-7.2/getPackageHeader/kernel-headers-2.4.9-38.s390.hdr
- also tried "up2date -u --nox" with same result
- updated to kernel-2.4.9-38 material manually from mplinux1 updates copy ... .
- ran "up2date -l" again and this time it worked.


BTW:  the kernel 2.4.9-38 stuff does show up in the list of packages from the "up2date --show-all".


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.see decription
2.
3.
    

Additional info

Comment 1 Bill Goodrich 2003-09-25 18:38:58 UTC
closed due to lack of interest


Note You need to log in before you can comment on or make changes to this bug.