Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 970668 - qpid segfaults in qpid::ha::BrokerReplicator::disconnected
qpid segfaults in qpid::ha::BrokerReplicator::disconnected
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
2.3
All Linux
high Severity high
: 3.0
: ---
Assigned To: Alan Conway
Irina Boverman
: OtherQA, Reopened, TestCaseProvided
Depends On:
Blocks: 1030608
  Show dependency treegraph
 
Reported: 2013-06-04 10:36 EDT by Pavel Moravec
Modified: 2014-09-24 11:08 EDT (History)
8 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1030608 (view as bug list)
Environment:
Last Closed: 2014-09-24 11:08:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 15:00:06 EDT

  None (edit)
Description Pavel Moravec 2013-06-04 10:36:47 EDT
Description of problem:
When playing with newHA active-passive cluster (dont recall any details though), my broker segfaulted. Attached is abrt report.


Version-Release number of selected component (if applicable):
qpid-cpp-*-0.18-14


How reproducible:
???


Steps to Reproduce:
???


Actual results:
qpidd segfaults


Expected results:
no segfault


Additional info:
Comment 2 Pavel Moravec 2013-06-07 10:12:52 EDT
Reproducer:
- having usual cluster.conf (as per docs)
- relocating primary service (this can happen automatically after a primary broker failure / stop):

while true; do for i in 1 2 3; do clusvcadm -r service:qpidd-primary-service service:node${i}-qpidd-service; sleep 3; clustat; done; done
Comment 3 Pavel Moravec 2013-06-07 11:01:57 EDT
What's wrong:

(gdb) frame 8
#8  qpid::ha::BrokerReplicator::disconnected (this=0x1dba220) at qpid/ha/BrokerReplicator.cpp:878
878	    QPID_LOG(info, logPrefix << "Disconnected from " << primary);
(gdb) p logPrefix
$11 = "\000\000\000", <incomplete sequence \375>
(gdb) 

i.e. logPrefix is null. Why??
Comment 4 Alan Conway 2013-06-07 11:49:01 EDT
Possibly a race where BrokerReplicator is disconnected after being deleted, it might be fixed on trunk I recall a fix along those lines. Can you reproduce easily?
Comment 5 Pavel Moravec 2013-06-10 07:03:57 EDT
(In reply to Alan Conway from comment #4)
> Possibly a race where BrokerReplicator is disconnected after being deleted,
> it might be fixed on trunk I recall a fix along those lines. Can you
> reproduce easily?

When I generate lots of clients (dis)connections like using below script, then it's almost certainty to get the segfault in 30 minutes on one node:


min=3
while true; do
	for i in 1 2 3; do
		if [ $(ps aux | grep qpid-send | grep -c "node${i}") -lt $min ]; then
			qpid-send -a "amq.fanout" -m 1 -b node${i} --connection-option="{reconnect:true, 'reconnect_limit':'1000', 'reconnect_interval_max':0 }" &
		fi
	done
done
Comment 6 Alan Conway 2013-10-16 17:36:42 EDT
I can't reproduce on the current 0.22-mrg which is at 

6006677 bz1019645: QPID-5239: preserve type of 'annotations' i.e. application properties added by broker

Please confirm if the bug still exists.
Comment 7 Pavel Moravec 2013-10-17 05:54:42 EDT
(In reply to Alan Conway from comment #6)
> I can't reproduce on the current 0.22-mrg which is at 
> 
> 6006677 bz1019645: QPID-5239: preserve type of 'annotations' i.e.
> application properties added by broker
> 
> Please confirm if the bug still exists.

Indeed, I can't replicate it further as well.

Closing it.
Comment 12 errata-xmlrpc 2014-09-24 11:08:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.