Bug 970681 - [cli] empty errata list shown for synced RHEL content
[cli] empty errata list shown for synced RHEL content
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Mike McCune
Og Maciel
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 11:03 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:18:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mmccune: needinfo+


Attachments (Terms of Use)
logs (1.52 MB, application/gzip)
2013-06-04 11:05 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2013-06-04 11:03:14 EDT
Description of problem:
Having synced RHEL6Server I do see no erratas listed for it. It just returns empty list.
Package list however works.

Version-Release number of selected component (if applicable):
candlepin-0.8.9-1.el6_4.noarch
candlepin-cert-consumer-cfseserver2.usersys.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.2-8.el6sat.noarch
katello-agent-1.4.2-4.el6sat.noarch
katello-all-1.4.2-8.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-6.el6sat.noarch
katello-cli-common-1.4.2-6.el6sat.noarch
katello-common-1.4.2-8.el6sat.noarch
katello-configure-1.4.3-12.el6sat.noarch
katello-configure-foreman-1.4.3-12.el6sat.noarch
katello-foreman-all-1.4.2-8.el6sat.noarch
katello-glue-candlepin-1.4.2-8.el6sat.noarch
katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
katello-glue-pulp-1.4.2-8.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.3-3.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-rpm-handlers-2.1.1-1.el6sat.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.1.1-1.el6sat.noarch
python-pulp-common-2.1.1-1.el6sat.noarch
python-pulp-rpm-common-2.1.1-1.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
python-rhsm-1.8.0-1.pulp.el6sat.x86_64
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.8-4.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-4.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
signo-katello-0.0.15-1.el6sat.noarch


How reproducible:
always

Steps to Reproduce:
1.make import manifest, enable repo and sync it. Details:
errata list --product "Red Hat Enterprise Linux Server" --repo "Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server"
2.
3.

Actual results:
empty list

Expected results:
Plenty of erratas to return for RHEL6Server latest.

Additional info:
It's a regression issue and we need to have it fixed. thanks
Comment 1 Garik Khachikyan 2013-06-04 11:05:10 EDT
Created attachment 756843 [details]
logs
Comment 2 Mike McCune 2013-06-06 12:25:12 EDT
works for me:

[root@6 ~]# katello repo list |grep 6Server
50  Red Hat Enterprise Linux 6 Server - Supplementary RPMs x86_64 6Server Red_Hat_Enterprise_Linux_6_Server_-_Supplementary_RPMs_x86_64_6Server 0             never               
19  Red Hat Enterprise Linux 6 Server ISOs i386 6Server                   Red_Hat_Enterprise_Linux_6_Server_ISOs_i386_6Server                   0             never               
20  Red Hat Enterprise Linux 6 Server ISOs x86_64 6Server                 Red_Hat_Enterprise_Linux_6_Server_ISOs_x86_64_6Server                 0             never               
9   Red Hat Enterprise Linux 6 Server RPMs i386 6Server                   Red_Hat_Enterprise_Linux_6_Server_RPMs_i386_6Server                   0             never               
10  Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server                 Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6Server                 10576         2013/06/05 05:13:07 
[root@6 ~]# katello errata list  --repo_id=10 
--------------------------
                                                                                                           Errata List

ID              Title                                                                                   Type        
--------------------------
RHBA-2010:0836  NetworkManager bug fix and enhancement update                                           bugfix      
RHBA-2010:0844  cluster and gfs2-utils bug fix update                                                   bugfix      
RHBA-2010:0845  selinux-policy bug fix update                                                           bugfix      
RHBA-2010:0846  yum bug fix update                                                                      bugfix      
RHBA-2010:0847  tuned bug fix update                                                                    bugfix      
RHBA-2010:0848  upstart bug fix update                                                                  bugfix      
RHBA-2010:0849  lvm2 bug fix update                                                                     bugfix      
RHBA-2010:0850  python-gudev bug fix update                                                             bugfix      
RHBA-2010:0852  sssd bug fix update                                                                     bugfix      
RHBA-2010:0853  xguest bug fix update                                                                   bugfix      
RHBA-2010:0855  qemu-kvm bug fix update                                                                 bugfix      
RHBA-2010:0856  kabi-whitelists bug fix update                                                          bugfix      
RHBA-2010:0857  lldpad bug fix update                                                                   bugfix      
RHBA-2010:0877  dracut bug fix update                                                                   bugfix      
RHBA-2010:0901  net-snmp bug fix update                                                                 bugfix      
RHBA-2010:0905  pixman bug fix update                                                                   bugfix      
...
Comment 3 Garik Khachikyan 2013-06-07 04:08:58 EDT
will check this one+ time. thanks.
Comment 5 Corey Welton 2013-06-19 11:04:52 EDT
Garik, can you retest this? Dev was not able to repro.  Please close it out if you no longer see the behavior.
Comment 6 Og Maciel 2013-06-19 11:17:25 EDT
Works for me with latest code.

VERIFIED:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10011-1.noarch
* foreman-compute-1.1.10011-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10011-1.noarch
* foreman-postgresql-1.1.10011-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-14.el6sat.noarch
* katello-all-1.4.2-14.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-14.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-14.el6sat.noarch
* katello-glue-candlepin-1.4.2-14.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
* katello-glue-pulp-1.4.2-14.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
* pulp-selinux-2.1.2-0.3.beta.el6sat.noarch
* pulp-server-2.1.2-0.3.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.18-1.el6sat.noarch
* signo-katello-0.0.18-1.el6sat.noarch
Comment 7 Mike McCune 2013-07-18 17:18:46 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.