Bug 970684 - [cli] distribution info for synced RHEL6 repo shows up with error
[cli] distribution info for synced RHEL6 repo shows up with error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Garik Khachikyan
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 11:08 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:19:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (1.52 MB, application/gzip)
2013-06-04 11:08 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2013-06-04 11:08:17 EDT
Created attachment 756844 [details]
logs

Description of problem:
"Resource not found on the server" thrown back on requesting distribution info for a synced RHEL6 repo.

Version-Release number of selected component (if applicable):
candlepin-0.8.9-1.el6_4.noarch
candlepin-cert-consumer-cfseserver2.usersys.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.2-8.el6sat.noarch
katello-agent-1.4.2-4.el6sat.noarch
katello-all-1.4.2-8.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-6.el6sat.noarch
katello-cli-common-1.4.2-6.el6sat.noarch
katello-common-1.4.2-8.el6sat.noarch
katello-configure-1.4.3-12.el6sat.noarch
katello-configure-foreman-1.4.3-12.el6sat.noarch
katello-foreman-all-1.4.2-8.el6sat.noarch
katello-glue-candlepin-1.4.2-8.el6sat.noarch
katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
katello-glue-pulp-1.4.2-8.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.3-3.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-rpm-handlers-2.1.1-1.el6sat.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.1.1-1.el6sat.noarch
python-pulp-common-2.1.1-1.el6sat.noarch
python-pulp-rpm-common-2.1.1-1.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
python-rhsm-1.8.0-1.pulp.el6sat.x86_64
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.8-4.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-4.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
signo-katello-0.0.15-1.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1.sync RHEL6 repo. Details:
distribution info --repo "Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server" --id "ks-Red Hat Enterprise Linux-Server-6.4-x86_64"
2.
3.

Actual results:
error above

Expected results:
correctly displaying the ks info

Additional info:
logs attached. Seems to be a regression.
Comment 1 Brad Buckingham 2013-06-04 19:40:31 EDT
A similar error occurs in the UI as well.  We should address both UI and API/CLI as part of the resolution to this one.
Comment 2 Brad Buckingham 2013-06-05 17:11:57 EDT
katello pull request:

https://github.com/Katello/katello/pull/2433

This fixed several issues with being able to support distributions.  The following is a summary of the fixes:

    fix ability to delete distributions (UI/CLI/API)
    fix ability to promote distributions (UI/CLI/API)
    fix the ability to view distributions (UI/CLI/API)
    fix the ability to view distribution file list (UI/CLI/API)
Comment 4 Brad Buckingham 2013-06-06 17:58:33 EDT
Mass move to ON_QA
Comment 6 Garik Khachikyan 2013-06-10 07:53:40 EDT
# VERIFIED

now the command returns with correct info back:
---
katello> distribution info --repo_id 6 --id "ks-Red Hat Enterprise Linux-Server-6.3-x86_64"
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
                                                                                            Distribution Information
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

ID          : ks-Red Hat Enterprise Linux-Server-6.3-x86_64
Family      : Red Hat Enterprise Linux
Variant     : Server
Version     : 6.3
Files:
    images/pxeboot/initrd.img
    images/pxeboot/vmlinuz
    images/boot.iso
    images/efiboot.img
    images/install.img
    images/efidisk.img
    images/product.img

Verified against:
---
candlepin-0.8.9-1.el6_4.noarch
candlepin-cert-consumer-dell-pe830-02.rhts.eng.bos.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.2-10.el6sat.noarch
katello-agent-1.4.3-1.git.1.24fe511.el6.noarch
katello-all-1.4.2-10.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.2-7.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
katello-common-1.4.2-10.el6sat.noarch
katello-configure-1.4.3-14.el6sat.noarch
katello-configure-foreman-1.4.3-14.el6sat.noarch
katello-foreman-all-1.4.2-10.el6sat.noarch
katello-glue-candlepin-1.4.2-10.el6sat.noarch
katello-glue-elasticsearch-1.4.2-10.el6sat.noarch
katello-glue-pulp-1.4.2-10.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.3-3.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-rpm-handlers-2.1.1-1.el6sat.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.1.1-1.el6sat.noarch
python-pulp-common-2.1.1-1.el6sat.noarch
python-pulp-rpm-common-2.1.1-1.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
python-rhsm-1.8.0-1.pulp.el6sat.x86_64
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.8-5.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-4.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
signo-katello-0.0.16-1.el6sat.noarch
Comment 7 Mike McCune 2013-07-18 17:19:33 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.