Bug 970689 - supermin fails to install from deb packages
supermin fails to install from deb packages
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 11:34 EDT by Nimimo
Modified: 2013-06-05 05:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-05 05:47:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nimimo 2013-06-04 11:34:29 EDT
supermin is from git

supermin -v -v -v -v -o supermin.d --save-temps blah/blah/*.deb
supermin 4.1.1
selected package handler: debian
unpacking blah/blah/adduser_3.113+nmu3ubuntu1_all.deb ...
Fatal error: exception Unix.Unix_error(20, "mkdir", "/tmp/supermin2ae46894c9f53495c4924527fe650069.tmp/blah/blah/adduser_3.113+nmu3ubuntu1_all.deb.d")

(cd blah/blah; supermin -v -v -v -v -o /home/blah/supermin.d --save-temps *.deb; )
supermin 4.1.1
selected package handler: debian
unpacking adduser_3.113+nmu3ubuntu1_all.deb ...
dpkg-deb: error: failed to read archive `/tmp/supermin5c38dbe94f478a28b891da08ffb41bdb.tmp/adduser_3.113+nmu3ubuntu1_all.deb': No such file or directory
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
supermin: umask 0000; dpkg-deb --fsys-tarfile /tmp/supermin5c38dbe94f478a28b891da08ffb41bdb.tmp/adduser_3.113+nmu3ubuntu1_all.deb | (cd /tmp/supermin5c38dbe94f478a28b891da08ffb41bdb.tmp/adduser_3.113+nmu3ubuntu1_all.deb.d && tar xf -): command failed, see earlier errors
Comment 2 Nimimo 2013-06-04 12:17:13 EDT
This works with both kinds of paths.  Thanks!
Comment 3 Richard W.M. Jones 2013-06-04 12:20:14 EDT
Closing based on verification comment 2.

Fix will appear in the next release (4.1.2 probably)
Comment 4 Nimimo 2013-06-04 16:49:40 EDT
I just noticed the change breaks downloaded packages.
Comment 5 Richard W.M. Jones 2013-06-05 05:20:41 EDT
Please verify 922527132403f79d82a0d2cb457b2a7cbc7dbbe8.
Comment 6 Nimimo 2013-06-05 05:47:05 EDT
This works in all cases — with package names and package paths.

Note You need to log in before you can comment on or make changes to this bug.