Bug 97069 - Version 3.3-4.x86_64 of gcc fails with internal errors
Summary: Version 3.3-4.x86_64 of gcc fails with internal errors
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-09 20:51 UTC by Michal Jaegermann
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 17:47:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source causing a compiler error (71.76 KB, text/plain)
2003-06-09 20:52 UTC, Michal Jaegermann
no flags Details
Another preprocessed compiler tripping source (62.20 KB, text/plain)
2003-06-09 20:54 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2003-06-09 20:51:26 UTC
Description of problem:

After installing gcc-3.3-4.x86_64, and other related packages,  I started
to get compilation errors like that:

gcc -c -DLOCALEDIR=\"/usr/local/share/locale\"
-DLOCALE_ALIAS_PATH=\"/usr/local/share/locale\" -DLIBDIR=\"/usr/local/lib\"
-DIN_LIBINTL -DHAVE_CONFIG_H -I.. -I. -I../intl  -g -O2 -Wall  bindtextdom.c
bindtextdom.c: In function `set_binding_values':
bindtextdom.c:341: internal compiler error: Segmentation fault

This is a file from  a development version of 'gawk' although this particular
one is likely not changed for quite some time.  In any case I attach two
preprocessed source files which consistently cause errors like the one
above.  This happens independently on a used optimization level - ranging
from none to -O3.

After reverting to the original gcc-3.2.2-10.x86_64 from GinGin64 everything
compiled, and even run :-), again.

Comment 1 Michal Jaegermann 2003-06-09 20:52:57 UTC
Created attachment 92283 [details]
Preprocessed source causing a compiler error

Comment 2 Michal Jaegermann 2003-06-09 20:54:28 UTC
Created attachment 92284 [details]
Another preprocessed  compiler tripping source

Comment 3 Jakub Jelinek 2003-06-11 20:54:40 UTC
I certainly cannot reproduce this with gcc-3.3-5.
Can you please try that (it is in rawhide)?

Comment 4 Michal Jaegermann 2003-06-11 23:08:56 UTC
Indeed, with gcc-3.3-5 this compilation, and few others so far,
worked fine without any surprises.

BTW - 'jdkgcj' package from "preview" prevents a clean compiler update
although this is not a very big problem. :-)

Comment 5 Jakub Jelinek 2003-06-17 17:47:42 UTC
jdkgcj has been fired and shot. Will add Obsoletes in the next gcc3*.spec.


Note You need to log in before you can comment on or make changes to this bug.