Bug 970723 - cancel sync fails with 500 error
cancel sync fails with 500 error
Status: CLOSED DUPLICATE of bug 966949
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 13:24 EDT by Mike McCune
Modified: 2013-06-04 15:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 15:31:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (23.63 KB, image/png)
2013-06-04 13:24 EDT, Mike McCune
no flags Details

  None (edit)
Description Mike McCune 2013-06-04 13:24:05 EDT
Created attachment 756891 [details]
screenshot

I synced a small repo (~25M) which succeeded but then upon returning to the Sync Management page it still had a stuck progress bar at 0

See attached screens hot.

I tried to cancel the sync, but it generated an error:

[ERROR 2013-06-04 17:19:29 app 03da0d72ae5870ae8184cb6c14247df4 #8968] can't convert String into Integer (TypeError)
 | /opt/rh/ruby193/root/usr/share/gems/gems/runcible-0.4.8/lib/runcible/resources/task.rb:53:in `[]'
 | /opt/rh/ruby193/root/usr/share/gems/gems/runcible-0.4.8/lib/runcible/resources/task.rb:53:in `cancel'
 | /usr/share/katello/app/models/glue/pulp/repo.rb:497:in `cancel_sync'
 | /usr/share/katello/app/controllers/sync_management_controller.rb:128:in `destroy'
Comment 1 Justin Sherrill 2013-06-04 15:31:28 EDT

*** This bug has been marked as a duplicate of bug 966949 ***

Note You need to log in before you can comment on or make changes to this bug.