Bug 970753 - New Host Group > Environments: (possibly empty?) environments appear alongside content definition views
New Host Group > Environments: (possibly empty?) environments appear alongsid...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
low Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 15:09 EDT by Corey Welton
Modified: 2014-06-19 15:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-04 13:12:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen snippet (29.31 KB, image/png)
2013-06-04 15:11 EDT, Corey Welton
no flags Details

  None (edit)
Description Corey Welton 2013-06-04 15:09:31 EDT
Description of problem:

I'm not sure of the exact best way that we should display this; all I know is that it is confusing.

If a user creates multiple Environments (dev, qe, stage, prod) and then creates/promotes a content view definition (CVD) to an environment, this CVD inexplicably shows up alongside all the environments you have created with otherwise no differentiation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  In katello, create a promotion path, dev -> qe -> stage -> prod
2.  Sync RHEL content and create a CVD; publish it; promote this CVD to dev.
3.  In foreman, More > Configuration > Host Groups > New Host Group
4.  Go to the Environment dropdown and view its contents

Actual results:
Something like
ACME_Corporation
  dev
  published_def
  prod
  qe
  stage


Expected results:

Not exactly sure, but here are some ideas
* Don't show environments which have no published CVDs?
* Don't show environments at all, opting instead to prepend an environment name to the CVD, i.e., "[Dev] published_def"?
* Somehow otherwise differentiate definitions from the environments themselves?

Additional info:
Comment 1 Corey Welton 2013-06-04 15:11:28 EDT
Created attachment 756927 [details]
screen snippet
Comment 2 Corey Welton 2013-06-05 15:48:28 EDT
This seems to be the case in Chrome/webkit.  Firefox correctly indents the CVD, i.e., 

dev
   published def
prod
qe
stage

lowering priority.
Comment 6 Bryan Kearney 2014-06-04 13:12:20 EDT
This is from the old UI, and is not relevant. We are closing based on that. If you feel this was done in error, please reopen.

Note You need to log in before you can comment on or make changes to this bug.