Bug 970759 - [RHSC] Creating Striped-Replicate Volume via Gluster does not sync with RHSC
[RHSC] Creating Striped-Replicate Volume via Gluster does not sync with RHSC
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Sahina Bose
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 15:25 EDT by Matt Mahoney
Modified: 2013-09-23 18:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: bb5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Volume Crteate Sync (3.13 MB, application/x-tar)
2013-06-04 15:25 EDT, Matt Mahoney
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15381 None None None Never

  None (edit)
Description Matt Mahoney 2013-06-04 15:25:16 EDT
Created attachment 756938 [details]
Volume Crteate Sync

Description of problem:
While testing Volume Create syncing with RHSC, the following volume when created via gluster did not sync with RHSC:

volume create demo-striped-replicate stripe 2 replica 2 10.8.30.25:/demo/stripedReplicateBrick1 10.8.30.25:/demo/stripedReplicateBrick2  10.8.30.26:/demo/stripedReplicateBrick1 10.8.30.26:/demo/stripedReplicateBrick2 force

Gluster volume info command shows the following:

Volume Name: demo-striped-replicate
Type: Striped-Replicate
Volume ID: e5062b05-94b8-45fc-9af8-c60a3e4ba1b5
Status: Created
Number of Bricks: 1 x 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: 10.8.30.25:/demo/stripedReplicateBrick1
Brick2: 10.8.30.25:/demo/stripedReplicateBrick2
Brick3: 10.8.30.26:/demo/stripedReplicateBrick1
Brick4: 10.8.30.26:/demo/stripedReplicateBrick2


Version-Release number of selected component (if applicable):

bb2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Volume should have synced with RHSC

Additional info:
Comment 2 Sahina Bose 2013-06-05 03:17:21 EDT
From logs - 
2013-06-04 14:52:01,075 ERROR [org.ovirt.engine.core.bll.gluster.GlusterSyncJob] (DefaultQuartzScheduler_Worker-32) Error while refreshing Gluster lightweight data of cluster Matts_Cluster!: org.ovirt.engine.core.common.errors.VdcBLLException: VdcBLLException: java.lang.IllegalArgumentException: No enum constant org.ovirt.engine.core.common.businessentities.gluster.GlusterVolumeType.STRIPED_REPLICATE (Failed with VDSM error ENGINE and code 5001)
	at org.ovirt.engine.core.bll.VdsHandler.handleVdsResult(VdsHandler.java:127) [bll.jar:]
Comment 3 Sahina Bose 2013-06-05 06:48:40 EDT
Changing priority as STRIPED_REPLICATE volume type is not supported in RHS
Comment 4 Shruti Sampat 2013-07-09 01:17:20 EDT
Verified as fixed in Red Hat Storage Console Version: 2.1.0-0.bb5.el6rhs. Striped-replicate volume created from gluster CLI now syncing with engine.
Comment 5 Scott Haines 2013-09-23 18:25:43 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.