This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 970827 - [whql][block]BSOD(7A) happened for job "Sleep and PNP (disable and enable) with IO Before and After (Certification)" on win8-32/64/win2012
[whql][block]BSOD(7A) happened for job "Sleep and PNP (disable and enable) wi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
high Severity urgent
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 22:40 EDT by lijin
Modified: 2014-01-01 11:36 EST (History)
7 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-68
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:36:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lijin 2013-06-04 22:40:01 EDT
Description of problem:
guest get BSOD with code 7A for job "Sleep and PNP (disable and enable) with IO Before and After (Certification)" on win8-32/64/win2012

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-0.12.1.2-2.359.el6.x86_64
kernel-2.6.32-358.el6.x86_64
seabios-0.6.1.2-27.el6.x86_64
vgabios-0.6b-3.7.el6.noarch
virtio-win-prewhql-63

How reproducible:
100%

Steps to Reproduce:
1.boot guest with following command:
/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic,family=0xf,+sep -usb -device usb-tablet -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup0,downscript=no -device e1000,netdev=hostnet0,mac=00:52:26:26:82:02 -uuid f5926489-1c6a-4f7e-a275-ae549f59ef44 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32-blk,server,nowait -mon chardev=111a,mode=readline -vnc :2 -name win8-32-blk-63 -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -drive file=win8-32-actived-1225.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=blk-disk0 -drive file=test.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=blk-disk1 -device virtio-blk-pci,drive=blk-disk0,id=disk,bootindex=1 -device virtio-blk-pci,drive=blk-disk1,id=disk1 -monitor stdio -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -M rhel6.4.0 -vga cirrus

2.Run job "Sleep and PNP(disable and enbale) with IO Before and After(Certification)"


Actual results:
guest bsod with code:7a

Expected results:
no bsod,job can pass

Additional info:
Comment 1 lijin 2013-06-04 22:40:47 EDT
1: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

KERNEL_DATA_INPAGE_ERROR (7a)
The requested page of kernel data could not be read in.  Typically caused by
a bad block in the paging file or disk controller error. Also see
KERNEL_STACK_INPAGE_ERROR.
If the error status is 0xC000000E, 0xC000009C, 0xC000009D or 0xC0000185,
it means the disk subsystem has experienced a failure.
If the error status is 0xC000009A, then it means the request failed because
a filesystem failed to make forward progress.
Arguments:
Arg1: c040b450, lock type that was held (value 1,2,3, or PTE address)
Arg2: c00000c0, error status (normally i/o status code)
Arg3: 1d0ea860, current process (virtual address for lock type 3, or PTE)
Arg4: 8168a3e5, virtual address that could not be in-paged (or PTE contents if arg1 is a PTE address)

Debugging Details:
------------------


ERROR_CODE: (NTSTATUS) 0xc00000c0 - This device does not exist.

BUGCHECK_STR:  0x7a_c00000c0

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

PROCESS_NAME:  sppsvc.exe

CURRENT_IRQL:  0

TRAP_FRAME:  91adb77c -- (.trap 0xffffffff91adb77c)
ErrCode = 00000010
eax=93f20400 ebx=91cdecc0 ecx=00000000 edx=00000000 esi=91adbd00 edi=00000000
eip=8168a3e5 esp=91adb7f0 ebp=91adb8bc iopl=0         nv up ei pl zr na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010246
nt! ?? ::NNGAKEGL::`string'+0xf2ae:
8168a3e5 0000            add     byte ptr [eax],al          ds:0023:93f20400=06
Resetting default scope

MISALIGNED_IP: 
nt! ?? ::NNGAKEGL::`string'+f2ae
8168a3e5 0000            add     byte ptr [eax],al

LAST_CONTROL_TRANSFER:  from 813fa10c to 8135bcb0

STACK_TEXT:  
91adb5f4 813fa10c 0000007a c040b450 c00000c0 nt!KeBugCheckEx
91adb65c 812b37ed 91adb6b8 81477140 91adb6c0 nt! ?? ::FNODOBFM::`string'+0x23696
91adb6dc 8129e402 81477140 8168a3e5 8ad004d0 nt!MiIssueHardFault+0x15a
91adb764 813d2654 00000008 8168a3e5 00000000 nt!MmAccessFault+0x285
91adb764 8168a3e5 00000008 8168a3e5 00000000 nt!KiTrap0E+0xdc
91adb8bc 813ec0fe 91adbd00 00000000 00000001 nt! ?? ::NNGAKEGL::`string'+0xf2ae
91adbce4 813d002a 91adbd00 00000000 91adbd54 nt! ?? ::FNODOBFM::`string'+0x15222
91adbd4c 813d279a 0056104c 76fb9785 badb0d00 nt!CommonDispatchException+0x4a
91adbd4c 76fb9785 0056104c 76fb9785 badb0d00 nt!KiTrap0E+0x222
WARNING: Frame IP not in any known module. Following frames may be wrong.
0056104c 00000000 00000000 00000000 00000000 0x76fb9785


STACK_COMMAND:  kb

FOLLOWUP_IP: 
nt! ?? ::FNODOBFM::`string'+23696
813fa10c 81fb16000080    cmp     ebx,80000016h

SYMBOL_STACK_INDEX:  1

SYMBOL_NAME:  nt! ?? ::FNODOBFM::`string'+23696

FOLLOWUP_NAME:  MachineOwner

IMAGE_NAME:  hardware

DEBUG_FLR_IMAGE_TIMESTAMP:  0

MODULE_NAME: hardware

FAILURE_BUCKET_ID:  IP_MISALIGNED

BUCKET_ID:  IP_MISALIGNED

Followup: MachineOwner
---------
Comment 3 Vadim Rozenfeld 2013-06-05 02:53:04 EDT
can you please upload the relevant crash dump file?
thanks,
Vadim.
Comment 5 Vadim Rozenfeld 2013-08-31 06:05:50 EDT
can we try reproducing the problem with drivers from build 68,
available at http://download.devel.redhat.com/brewroot/work/tasks/7431/6217431/virtio-win-prewhql-0.1.zip ?

Thank you,
Vadim.
Comment 6 Mike Cao 2013-10-08 02:22:46 EDT
Verified this issue on virtio-win-prewhql-71 

Steps same as comment #0 

Actual Results:
"Sleep and PNP (disable and enable) with IO before and after " job can pass without BSOD 

Based on above ,this issue has been fixed ald 

Move status to VERIFIED

Note You need to log in before you can comment on or make changes to this bug.