Bug 970837 - Not handling timeout when checking http status of app after migrate
Not handling timeout when checking http status of app after migrate
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 23:52 EDT by Wesley Hearn
Modified: 2015-05-14 19:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:16:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Hearn 2013-06-04 23:52:23 EDT
Description of problem:
Running rhc-admin-migrate will error with
Caught an exception during internal migration steps: Timeout::Error
/opt/rh/ruby193/root/usr/share/ruby/net/protocol.rb:146:in `rescue in rbuf_fill'
/opt/rh/ruby193/root/usr/share/ruby/net/protocol.rb:140:in `rbuf_fill'
/opt/rh/ruby193/root/usr/share/ruby/net/protocol.rb:122:in `readuntil'
/opt/rh/ruby193/root/usr/share/ruby/net/protocol.rb:132:in `readline'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:2563:in `read_status_line'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:2552:in `read_new'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:1320:in `block in transport_request'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:1317:in `catch'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:1317:in `transport_request'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:1294:in `request'
/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/net_http_ext.rb:17:in `request'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:1287:in `block in request'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:746:in `start'
/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:1285:in `request'
/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/net_http_ext.rb:17:in `request'
/opt/rh/ruby193/root/usr/libexec/mcollective/mcollective/lib/migrate.rb:655:in `validate_gear'
/opt/rh/ruby193/root/usr/libexec/mcollective/mcollective/lib/migrate.rb:186:in `migrate'
/opt/rh/ruby193/root/usr/libexec/mcollective/mcollective/agent/libra.rb:68:in `migrate_action'
/opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/agent.rb:86:in `handlemsg'
/opt/rh/ruby193/root/usr/share/ruby/mcollective/agents.rb:126:in `block (2 levels) in dispatch'
/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'
/opt/rh/ruby193/root/usr/share/ruby/mcollective/agents.rb:125:in `block in dispatch'
Migrate on node exit code: 1
        from /usr/bin/rhc-admin-migrate:38:in `migrate_gear'
        from /usr/bin/rhc-admin-migrate:713:in `<main>'

If it takes too long to get back the HTTP status of the gear.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Dan McPherson 2013-06-05 13:35:22 EDT
https://github.com/openshift/li/pull/1549
Comment 2 Meng Bo 2013-06-06 05:46:14 EDT
Checked issue on devenv-stage_360,

Upgrade from devenv-stage_353 to devenv-stage_360, and do migration.

Following log found for the gear, 503 error will be skipped.


Starting gear with uuid '822c8ae6ce8c11e2964312313d14f574' on node 'ip-10-85-2-130'
Start gear output: CLIENT_MESSAGE: Starting Apache+mod_php HTTPD server

Marking step start_gear complete
Validating gear 822c8ae6ce8c11e2964312313d14f574 post-migration
Pre-migration state: started
Post-migration response code: 503
Leaving migration metadata in place due to problem detected with gear status:
Cart status for php [PROBLEM]: CLIENT_RESULT: Application is either stopped or inaccessible

***time_migrate_on_node_measured_from_node=39765***
Resetting quota blocks: 1048576  inodes: 40000
***time_redeploy_httpd_proxy=0***
***time_restart=0***
***time_total_migrate_gear_measured_from_broker=40766***

Note You need to log in before you can comment on or make changes to this bug.