Bug 97091 - cups won't share canon printer via samba
cups won't share canon printer via samba
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-10 06:00 EDT by Adam Wood
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-12 07:11:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Wood 2003-06-10 06:00:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Have two printers installed, a HP LaserJet 6L and a Canon BJC 4310SP.
Both printers print locally, but only the HP printer will print from the LAN 
via samba.Both printers are seen to be active and in a "ready" state on the 
networked windows machines, but nothing happens when a print job is sent to 
the Canon printer.
Have removed the HP printer and expansion ISA card and still the same result, 
even with a fresh install of RH9.
Both printers worked faultlessly with cups in RedHat 8 and are working 
currently with LPRng, but if I switch, using the RH printer switch tool, and 
change smb.conf back to cups I lose the Canon printer via samba.


Version-Release number of selected component (if applicable):
cups-1.1.17-13.3

How reproducible:
Always

Steps to Reproduce:
1.kudzu detects Canon printer and configures on first boot. 
2.Configure cups for Canon BJC 4300SP using RH gui
3.Configure Samba for printer sharing (normally via swat or webmin)
3.Print test page on windows machine, via samba, connected to LAN
    

Actual Results:  activity lights on switch, no activity at printer

Expected Results:  printer prints test page

Additional info:

I have check all log files for any error messages, but there appears to be 
none.
As stated before only the Canon printer is affected, not the HP printer.
Comment 1 Tim Waugh 2003-06-10 11:10:00 EDT
If it prints locally, there's no problem with CUPS.  Jobs from samba shares are
submitted by samba, locally, so the first thing to check is if it is actually
submitting the jobs.

Set LogLevel to debug in /etc/cups/cupsd.conf and do 'service cups reload'. 
When you submit a job to the samba share, are there any messages about
processing the job in /var/log/cups/error_log?
Comment 2 Adam Wood 2003-06-11 00:49:29 EDT
This is the print job in the error log with debug enabled..

D [11/Jun/2003:14:35:42 +1000] ReadClient() 6 POST /printers/BJC HTTP/1.1
D [11/Jun/2003:14:35:42 +1000] print_job: auto-typing file...
E [11/Jun/2003:14:35:42 +1000] print_job: Unsupported format
'application/octet-stream'!
I [11/Jun/2003:14:35:42 +1000] Hint: Do you have the raw file printing rules
enabled?
D [11/Jun/2003:14:35:42 +1000] Sending error:
client-error-document-format-not-supported
D [11/Jun/2003:14:35:42 +1000] ProcessIPPRequest: 6 status_code=40a
D [11/Jun/2003:14:35:42 +1000] CloseClient() 6

My HP printer still works via samba/cups, the only line changed for the cups
change over in samba was the "printing = cups".

Out of interest (and not knowing any better) I changed the print processor and
data type in windows. Using WinPrint and Canon Print Processor and changing the
type from RAW to NT EMF and also TEXT, but I still get the same message in the
log as shown above.
Comment 3 Tim Waugh 2003-06-11 04:56:09 EDT
Perhaps you need to set the Linux queue to be a raw queue (using the System
Settings->Printing tool) and tell the Windows machine the printer model; i.e.
use the printer driver on the Windows side.

Since the HP queue works, what are the settings for that on the Windows end?
Comment 4 Adam Wood 2003-06-12 00:37:02 EDT
On the windows side of things I have always used the factory drivers, selecting
the correct model.
samba.conf also contains the line under [printers]"use client driver = Yes".
I have edited the print queue (using Print tool) and change the printer driver
to generic - raw print queue.
I can now print to the canon printer via samba.
The default HP driver settings for windows is HPPRN02 processor and RAW.
The default Canon driver settings for windows is Canon BJC-4300SP Print
Processor and RAW.
The windows side of things have not changed since doing a fresh install of
RedHat 9 from the previous version of RedHat, where the Canon printer did work
using samba and cups. Cups was not the default but was selected using the
printer switch tool.
Comment 5 Tim Waugh 2003-06-12 07:11:04 EDT
It is intended behaviour that non-raw queues created using redhat-config-printer
reject application/octet-stream data.

There is a Windows IPP client available from www.cups.org.  For SMB printing,
either the Windows machine should be set to emit PostScript, or the Linux
machine should have a raw queue configured.

Note You need to log in before you can comment on or make changes to this bug.