Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 970943 - Update the console installation guide with Domain Management Tool information
Update the console installation guide with Domain Management Tool information
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Pavithra
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 05:47 EDT by Pavithra
Modified: 2015-05-17 21:23 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 16:17:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated DMT (295.79 KB, application/pdf)
2013-07-18 07:20 EDT, Pavithra
no flags Details
email reference (3.46 KB, text/plain)
2013-08-14 06:59 EDT, Pavithra
no flags Details
domain management tool section is added (264.23 KB, application/pdf)
2013-08-19 05:51 EDT, Pavithra
no flags Details
DMT comments incorporated (264.24 KB, application/pdf)
2013-08-21 05:28 EDT, Pavithra
no flags Details

  None (edit)
Description Pavithra 2013-06-05 05:47:46 EDT
Description of problem:
The console installation guide needs to be updated to include the domain management tool information.

Version-Release number of selected component (if applicable):
2.1

How reproducible:
always

Steps to Reproduce:
It is currently seen on page 27 of the console installation guide.

Actual results:
Currently there is no information about the Domain management tool

Expected results:
We need info similar to https://access.redhat.com/site/documentation//en-US/Red_Hat_Enterprise_Virtualization/3.2-Beta/html/Installation_Guide/appe-Additional_Utilities.html 

Additional info:
none
Comment 2 Pavithra 2013-07-18 07:20:22 EDT
Created attachment 775260 [details]
Updated DMT
Comment 3 Pavithra 2013-07-18 07:22:56 EDT
After a discussion with Sahina in the stand up meeting, I am moving this bug to ON_QA. Please review the attachment (page 29).
Comment 4 Pavithra 2013-08-14 06:59:15 EDT
Created attachment 786498 [details]
email reference
Comment 5 Pavithra 2013-08-14 07:01:26 EDT
Do let me know when this feature is tested. I need to document this in the 2.1 installation guide.
----------------------------------------------------------------
>> > Yaniv?
>>
>> well the functionality should work but make sure to test the 
>> installation/uninstall/upgrade/dependencies of it.
----------------------------------------------------------------

Please refer to the attachment for the entire email conversation.
Comment 6 Pavithra 2013-08-14 07:01:54 EDT
Do let me know when this feature is tested. I need to document this in the 2.1 installation guide.
----------------------------------------------------------------
>> > Yaniv?
>>
>> well the functionality should work but make sure to test the 
>> installation/uninstall/upgrade/dependencies of it.
----------------------------------------------------------------

Please refer to the attachment for the entire email conversation.
Comment 7 Pavithra 2013-08-19 05:50:38 EDT
I have attached the PDF here. I know that the "edit option" needs careful handling.
Comment 8 Pavithra 2013-08-19 05:51:29 EDT
Created attachment 787971 [details]
domain management tool section is added
Comment 9 Prasanth 2013-08-21 01:43:41 EDT
Following are the examples of DMT using AD:

-----------------------
# rhsc-manage-domains -action=add -domain='qe.redhat.com' -provider=ActiveDirectory -user='admin' -interactive
Enter password:

The domain qe.redhat.com has been added to the engine as an authentication source but no users from that domain have been granted permissions within the oVirt Manager.
Users from this domain can be granted permissions from the Web administration interface or by editing the domain using -action=edit and specifying -addPermissions.
oVirt Engine restart is required in order for the changes to take place (service ovirt-engine restart).
Manage Domains completed successfully

[root@rhs-client3 ~]# rhsc-manage-domains -action=validate
Domain qe.redhat.com is valid.
The configured user for domain qe.redhat.com is admin@QE.REDHAT.COM
Manage Domains completed successfully


[root@rhs-client3 ~]# rhsc-manage-domains -action=list
Domain: qe.redhat.com
        User name: admin@QE.REDHAT.COM
Manage Domains completed successfully


# rhsc-manage-domains -action=delete -domain='qe.redhat.com'
WARNING: Domain qe.redhat.com is the last domain in the configuration. After deleting it you will have to either add another domain, or to use the internal admin user in order to login.
Are you sure you like to delete domain qe.redhat.com (yes/no) :
yes
Successfully deleted domain qe.redhat.com. Please remove all users and groups of this domain using the Administration portal or the API. oVirt Engine restart is required in order for the changes to take place (service ovirt-engine restart).
Manage Domains completed successfully
-----------------------

Following is the output of edit option:

--------
# rhsc-manage-domains -action=edit -domain='qe.redhat.com' -provider=ActiveDirectory -interactive
Enter password:

oVirt Engine restart is required in order for the changes to take place (service ovirt-engine restart).
Manage Domains completed successfully
--------
Comment 10 Prasanth 2013-08-21 03:24:12 EDT
Verified. See review comments below:

--------
* A.1.2. Adding Domains to Configuration
    In this example, the rhsc-manage-domains command is used to add the IdM domain directory.demo.redhat.com to the Red Hat Storage Console configuration.

Change: "IdM" should be replaced with "ActiveDirectory" and "directory.demo.redhat.com" should be replaced with "test.redhat.com"

* In Page29: "Editing a Domain in the Configuration" on the right hand top should be removed


* A.1.3. Editing a Domain in the Configuration

Change: domain name should match with the example given

* A.1.4. Deleting a Domain from the Configuration

Change: domain name should match with the example given
--------
Comment 11 Pavithra 2013-08-21 05:28:40 EDT
Created attachment 788776 [details]
DMT comments incorporated
Comment 12 Pavithra 2013-08-21 05:28:57 EDT
In Page29: "Editing a Domain in the Configuration" on the right hand top should be removed
Prasanth,
That's the template of the book. It cannot be altered. The template picks up the first heading in that page and displays it as the header.

Here is the link to the doc on staging server:
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.1/html/Console_Installation_Guide/index.html

The staging server link will be updated after 4 hours. Please find the pdf in the attachment.
Comment 13 Scott Haines 2013-12-10 16:17:20 EST
Since the problem described in this bug report should be resolved in a recent
advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow
the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.