Bug 970950 - [whql][block]BSOD(7A) happened for job "Device Install Check for Other Device Stability(Certification)"&"Device Install Check for File System Consistency(Certification)" on win7-32/64 on HCK
[whql][block]BSOD(7A) happened for job "Device Install Check for Other Device...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 05:57 EDT by guo jiang
Modified: 2014-01-01 11:36 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:36:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description guo jiang 2013-06-05 05:57:35 EDT
Description of problem:
BSOD with error code F4 happened when run job "Device Install Check for Other Device Stability"&"Device Install Check for File System Consistency" on win7-32/64 on HCK


Version-Release number of selected component (if applicable):

    * Red Hat Enterprise Linux Server release 6.4 (Santiago)
    * kernel-2.6.32-369.el6.x86_64    
    * qemu-img-rhev-0.12.1.2-2.359.el6.x86_64
    * virtio-win-prewhql-0.1-61
    * spice-server-0.12.0-12.el6.x86_64
    * seabios-0.6.1.2-27.el6.x86_64
    * vgabios-0.6b-3.7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.Start guest with CLI:
/usr/libexec/qemu-kvm \
-M rhel6.4.0 -m 2G -smp 2,cores=2 -cpu cpu64-rhel6,+x2apic,family=0xe -usb -device usb-tablet -drive file=win7-32-block.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:13:23:24:3a:10,bus=pci.0,addr=0x6 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup0,downscript=no -device e1000,netdev=hostnet1,mac=00:22:45:31:41:10,bus=pci.0,addr=0x7 -uuid 47b70451-24ff-4733-8ec1-98e38f707ff1 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win7-32-block,server,nowait -mon chardev=111a,mode=readline -name win7-32-block -drive file=disk1.raw,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop,format=raw -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.raw,if=none,id=drive-virtio2,cache=none,werror=stop,rerror=stop,format=raw -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.raw,if=none,id=drive-virtio3,cache=none,werror=stop,rerror=stop,format=raw -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.raw,if=none,id=drive-virtio4,cache=none,werror=stop,rerror=stop,format=raw -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4 -vnc :1 -vga cirrus -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio

2.Run job  "Device Install Check for Other Device Stability(Certification)" or "Device Install Check for File System Consistency(Certification)" 

3.Run task "Run Test"

Actual results:
BSOD with error code F4 happened.

Expected results:
Job should passed without any error.

Additional info:
0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

CRITICAL_OBJECT_TERMINATION (f4)
A process or thread crucial to system operation has unexpectedly exited or been
terminated.
Several processes and threads are necessary for the operation of the
system; when they are terminated (for any reason), the system can no
longer function.
Arguments:
Arg1: 00000003, Process
Arg2: 8ad36408, Terminating object
Arg3: 8ad36574, Process image file name
Arg4: 82862eb0, Explanatory message (ascii)

Debugging Details:
------------------

Page 251c1 not present in the dump file. Type ".hh dbgerr004" for details

KERNEL_LOG_FAILING_PROCESS:  ‰

PROCESS_OBJECT: 8ad36408

IMAGE_NAME:  hardware_disk

DEBUG_FLR_IMAGE_TIMESTAMP:  0

FAULTING_MODULE: 00000000 

PROCESS_NAME:  csrss.exe

EXCEPTION_RECORD:  8e27ace0 -- (.exr 0xffffffff8e27ace0)
ExceptionAddress: 77beaabc
   ExceptionCode: c0000006 (In-page I/O error)
  ExceptionFlags: 00000000
NumberParameters: 3
   Parameter[0]: 00000008
   Parameter[1]: 77beaabc
   Parameter[2]: c000000e
Inpage operation failed at 77beaabc, due to I/O error c000000e

EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.

EXCEPTION_PARAMETER1:  00000008

EXCEPTION_PARAMETER2:  77beaabc

EXCEPTION_PARAMETER3:  c000000e

IO_ERROR: (NTSTATUS) 0xc000000e - A device which does not exist was specified.

FAULTING_IP: 
+0
77beaabc ??              ???

BUGCHECK_STR:  0xF4_IOERR_c000000e

STACK_TEXT:  
8e27a7a8 829283ad 000000f4 00000003 8ad36408 nt!KeBugCheckEx+0x1e
8e27a7cc 828a5fe5 82862eb0 8ad36574 8ad36678 nt!PspCatchCriticalBreak+0x71
8e27a7fc 828a5f28 8ad36408 8dd3e1f8 c0000006 nt!PspTerminateAllThreads+0x2d
8e27a830 826878ba ffffffff c0000006 8e27acc4 nt!NtTerminateProcess+0x1a2
8e27a830 82686b0d ffffffff c0000006 8e27acc4 nt!KiFastCallEntry+0x12a
8e27a8b0 826fe6ab ffffffff c0000006 0001003f nt!ZwTerminateProcess+0x11
8e27acc4 826884a6 8e27ace0 00000000 8e27ad34 nt!KiDispatchException+0x497
8e27ad2c 8268abeb 0152f8c4 77beaabc badb0d00 nt!CommonDispatchException+0x4a
8e27ad2c 77beaabc 0152f8c4 77beaabc badb0d00 nt!KiTrap0E+0x21f
WARNING: Frame IP not in any known module. Following frames may be wrong.
0152f8c4 00000000 00000000 00000000 00000000 0x77beaabc


STACK_COMMAND:  kb

FOLLOWUP_IP: 
+0
77beaabc ??              ???

SYMBOL_STACK_INDEX:  9

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: hardware_disk

FAILURE_BUCKET_ID:  0xF4_IOERR_c000000e_VRF_IMAGE_hardware_disk

BUCKET_ID:  0xF4_IOERR_c000000e_VRF_IMAGE_hardware_disk

Followup: MachineOwner
---------
Comment 2 Vadim Rozenfeld 2013-06-05 07:52:24 EDT
please upload the crash dump file.
Thanks,
Vadim.
Comment 5 Vadim Rozenfeld 2013-08-31 06:08:15 EDT
please retest with the latest drivers from build 68
http://download.devel.redhat.com/brewroot/work/tasks/7431/6217431/virtio-win-prewhql-0.1.zip.

thank you,
Vadim.
Comment 6 Mike Cao 2013-10-08 02:34:19 EDT
Verified this issue on virtio-win-prewhql-71 

Steps same as comment #0 

Actual Results:
"Sleep and PNP (disable and enable) with IO before and after " job can pass
without BSOD 

Based on above ,this issue has been fixed ald 

Move status to VERIFIED

Note You need to log in before you can comment on or make changes to this bug.