Bug 970983 - missing xml element within messaging subsystem
missing xml element within messaging subsystem
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: DR2
: EAP 6.3.0
Assigned To: sgilda
Russell Dickenson
: Documentation, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 07:47 EDT by Dominique Jean-Prost
Modified: 2015-06-01 07:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.8 Build Name: 11865, Administration and Configuration Guide-6.1-3 Build Date: 23-05-2013 10:40:22
Last Closed: 2014-06-28 11:40:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominique Jean-Prost 2013-06-05 07:47:30 EDT
Title: Configure the JMS Server

Describe the issue:
Documentation says in https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.1/html/Administration_and_Configuration_Guide/sect-Configuration.html that "

Add a new line just beneath the <subsystems> tag. Paste the following into it:
<subsystem xmlns="urn:jboss:domain:messaging:1.2">

</subsystem>
All further configuration will be added to the empty line above.

"
This is wrong. The element <hornetq-server> is missing.
Comment 2 Misty Stanley-Jones 2013-08-20 03:27:34 EDT
I'm not sure this is really the best way to go. Wouldn't you add the subsystem with a :add operation? I don't think we should be telling anyone to hack the XML.
Comment 3 Miroslav Novak 2013-08-28 05:30:22 EDT
Hi Misty, 

in this case it seems that there is confusion why there is:
<subsystem xmlns="urn:jboss:domain:messaging:1.3">
  ...
  
  ...
</subsystem>

and not:
<subsystem xmlns="urn:jboss:domain:messaging:1.3">
  <hornetq-server>
  ...
  
  ...
  </hornetq-server>
</subsystem>

in the doc. I believe that there always will be users who modify standalone-...xml directly. Updating it will make it clear to users.

Thanks,
Mirek
Comment 4 sgilda 2013-11-06 16:34:22 EST
I'll take this one.
Comment 5 sgilda 2013-11-06 16:38:29 EST
Made the following changes to topic 111:

Changed the name of the standalone configuration file to standalone-full.xml.
Changed the messaging subsystem version to 1.4.
Changed the instructions to add the text after the '<hornetq-server>' tag.
Added the <hornetq-server> tag to the example.
Comment 6 sgilda 2013-11-19 10:04:33 EST
Apparently my change did not save to PressGang. Moving this back to assigned.
Comment 9 Miroslav Novak 2014-02-27 05:22:07 EST
Verified. Thanks!
Comment 10 Miroslav Novak 2014-04-02 08:30:41 EDT
*** Bug 1080123 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.