Bug 970989 - [RHS-C] Reduce the hooks sync job time from 2hrs or make it user configurable
[RHS-C] Reduce the hooks sync job time from 2hrs or make it user configurable
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Sahina Bose
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 07:53 EDT by Prasanth
Modified: 2013-09-23 18:25 EDT (History)
8 users (show)

See Also:
Fixed In Version: bb4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15251 None None None Never

  None (edit)
Description Prasanth 2013-06-05 07:53:59 EDT
Description of problem:

Reduce the hooks sync job time from 2hrs or make it user configurable. 2hrs is not an acceptable limit as the admins will have to wait for a long time to see the hooks that they manually created.
Comment 2 Sahina Bose 2013-06-17 04:22:13 EDT
Provided an option via engine-config-tool to make the sync interval configurable.
Also, added a UI option for a user to initiate syncing of hooks with gluster servers.
Comment 3 Prasanth 2013-06-21 06:07:31 EDT
(In reply to Sahina Bose from comment #2)
> Provided an option via engine-config-tool to make the sync interval
> configurable.
> Also, added a UI option for a user to initiate syncing of hooks with gluster
> servers.

Can you provide the exact command to set this option using engine-config and its  accepted range of values?
Comment 4 Sahina Bose 2013-06-21 06:50:08 EDT
engine-config -s GlusterRefreshRateHooks=60 

The above command will set refresh rate to 60 seconds. Valid values are integers between 30 to 3600

Use "engine-config -h" to see help on the tool.
Comment 5 Prasanth 2013-06-21 08:04:18 EDT
(In reply to Sahina Bose from comment #4)
> engine-config -s GlusterRefreshRateHooks=60 
> 
> The above command will set refresh rate to 60 seconds. Valid values are
> integers between 30 to 3600
> 
> Use "engine-config -h" to see help on the tool.

Thanks Sahina.
Comment 6 Prasanth 2013-06-21 08:06:10 EDT
Verified as fixed in bb4

[root@rhs-client3 notifier]# engine-config -s GlusterRefreshRateHooks=30

[root@rhs-client3 notifier]# engine-config -g GlusterRefreshRateHooks
GlusterRefreshRateHooks: 30 version: general
Comment 7 Scott Haines 2013-09-23 18:25:44 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.