Bug 970996 - Horizon doesn't show quantum quota
Horizon doesn't show quantum quota
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: Upstream M3
: 4.0
Assigned To: Julie Pichon
Nir Magnezi
https://blueprints.launchpad.net/hori...
: Triaged
: 891309 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 08:22 EDT by Ofer Blaut
Modified: 2016-04-26 12:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-0.12b3.el6ost
Doc Type: Enhancement
Doc Text:
Project quotas for networking can now be viewed and managed in Dashboard. This enhancement requires Networking be enabled; with a backend plugin that supports quotas.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:04:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1109140 None None None Never

  None (edit)
Description Ofer Blaut 2013-06-05 08:22:24 EDT
Description of problem:

Horizon doesn't show quantum quota ,
Since this version support quantum network,subnet and topology 

There should be support for quantum quota as well

From CLI . nothing in GUI 

[root@puma04 ~(keystone_admin_tenant1)]# quantum quota-show 
+---------------------+-------+
| Field               | Value |
+---------------------+-------+ IN GUI i have part of these values : 
| floatingip          | 50    | <<< the value presented now is of nova 10 
| network             | 10    | <<<< Nothing
| port                | 50    | <<<< Nothing
| router              | 10    | <<<< Nothing
| security_group      | 10    | << Nova ones ? - 10 
| security_group_rule | 100   | << Nova ones?  - 20 
| subnet              | 10    | <<<< Nothing 
+---------------------+-------+




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Julie Pichon 2013-09-03 09:42:41 EDT
Prerequisites to test:

Install OpenStack with Neutron enabled and a backend that supports quotas (e.g. openvswitch).

In Horizon's local_settings.py, make sure 'enable_quotas' is set to True and restart httpd.

OPENSTACK_NEUTRON_NETWORK = {
    'enable_quotas': True,
}

What changed:

1. In the Default quotas, Floating IPs and Fixed IPs are not shown anymore (unfortunately, reading the Neutron default quotas via an API is not possible at this stage, so the Neutron quotas cannot be shown (cf. LP#1204956))

2. When updating a Project, the correct quotas coming from Neutron are shown.

3. (Maybe outside the scope of this bug, since the bug title is about showing?) They can also be updated via Modify Quotas via Admin -> Project.


Note this only covers the Floating IPs quotas. Security groups-related Neutron quotas will be handled separately and haven't been fixed upstream yet (cf. LP#1212600).
Comment 2 Julie Pichon 2013-09-03 11:14:58 EDT
Also, about #3, if you want to test updates make sure to use a Neutron quota driver that supports updates (e.g. neutron.db.quota_db.DbQuotaDriver, see https://bugs.launchpad.net/neutron/+bug/1189671)
Comment 3 Julie Pichon 2013-09-03 11:16:22 EDT
*** Bug 891309 has been marked as a duplicate of this bug. ***
Comment 6 Julie Pichon 2013-11-26 05:10:26 EST
More testing related information:

The places affected are the floating IPs graph on the Overview, the Project Quotas in the admin, and in the default quotas you shouldn't see the IP related quotas (e.g. no fixed IPs), as Neutron doesn't have an API yet for reading default quotas. The floating IP allocation screen in Access & Security also shows the quota.

Other paths interesting to test:

 * Nova-networking and related quotas should still work normally, when Neutron isn't installed

 * Possibly of interest (I don't know if it's one of our supported configurations): testing with a Neutron backend that doesn't support quotas. This can be 'faked' by having Neutron enabled and setting 'enable_quotas' to False. The assumption made here is that no quota support is equivalent to infinite quotas i.e. no limit, and the graphs should reflect this.
Comment 7 Nir Magnezi 2013-11-26 08:23:15 EST
Verified NVR: python-django-horizon-2013.2-5.el6ost.noarch

Tested 3 Configurations:

1. Neutron with quotas enabled:
   - Floating IPs graph on Project Overview:
     Visible - Floating IPs Used 0 of 50

   - Project Quotas in the admin tab: 
     Admin Tab --> Projects --> <Project Name> --> Modify Quotas
     Listed network related quotas:
      Security Groups
      Security Group Rules
      Floating IPs
      Networks
      Ports
      Routers
      Subnets

     * Quotas matched to the output of neutron quota-show command.
     * I managed to update the quota via horizon (verified with neutron quota-show via CLI)

   - Default Quotas:
     As expected No IP related quotas are present in the list.

   - Project --> Access & Security --> Floating  IPs --> Allocate IP To Project
     Indication of '50' Available floating IPs is present.


2. Neutron with quotas disabled:
   - Floating IPs graph on Project Overview: 
     Visible - Floating IPs Used 0 of inf

   - Project Quotas in the admin tab:
     Admin Tab --> Projects --> <Project Name> --> Modify Quotas
     Network related quotas are not listed (as expected).

   - Default Quotas:
     As expected No IP related quotas are present in the list.

   - Project --> Access & Security --> Floating  IPs --> Allocate IP To Project
     Indication of 'No Limit' Available floating IPs is present.


3. Nova-Network:
   - Floating IPs graph on Project Overview: 
     Visible - Floating IPs Used 0 of 10

   - Project Quotas in the admin tab:
     Admin Tab --> Projects --> <Project Name> --> Modify Quotas
     Listed network related quotas:
      Floating IPs
      Fixed IPs
      Security Groups
      Security Group Rules

   - Default Quotas:
     Listed network related quotas:
      Fixed IPs
      Security Groups

   - Project --> Access & Security --> Floating  IPs --> Allocate IP To Project
     Indication of '10' Available floating IPs is present.
Comment 9 errata-xmlrpc 2013-12-19 19:04:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.