Bug 971001 - CCE when using inline cast
CCE when using inline cast
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Mario Fusco
Tomas Schlosser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 08:41 EDT by Tomas Schlosser
Modified: 2014-08-06 16:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Schlosser 2013-06-05 08:41:05 EDT
Description of problem:
When a different class than required is found, the engine throws CCE.

Version-Release number of selected component (if applicable):
Drools 6.0.0.Beta3, Drools master (2013-06-05)

How reproducible:
Pull request with test submitted on github

Steps to Reproduce:
1. run testSuperclass JUnit test

Actual results:
Test fails with class cast exception.

Expected results:
Test passes fine.

Additional info:
Comment 1 Tomas Schlosser 2013-06-05 08:56:58 EDT
Submitted as pull request #208
Comment 3 Ryan Zhang 2013-07-11 02:17:30 EDT
*** Bug 971008 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Schlosser 2013-09-02 10:57:46 EDT
Verified in BRMS 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.