Bug 971008 - Inline cast does not work with matches operator
Inline cast does not work with matches operator
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: BRE (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: Mario Fusco
Tomas Schlosser
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 08:51 EDT by Tomas Schlosser
Modified: 2014-08-06 16:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Schlosser 2013-06-05 08:51:00 EDT
Description of problem:
Using matches operator with field extracted using inline cast can't be compiled.

Version-Release number of selected component (if applicable):
Drools 6.0.0.Beta3, Drools master (2013-06-05)

How reproducible:
Pull request with reproducer submitted on Github.

Steps to Reproduce:
1. run testMatchesOperator JUnit test

Actual results:
Package is not built, complaining about right side not being of type boolean

Expected results:
Package compiles fine and rules are evaluated correctly

Additional info:
Additional operators may be affected as well.
Comment 1 Tomas Schlosser 2013-06-05 08:56:50 EDT
Submitted as pull request #208
Comment 2 Ryan Zhang 2013-07-11 02:17:30 EDT

*** This bug has been marked as a duplicate of bug 971001 ***
Comment 3 Tomas Schlosser 2013-09-02 11:00:01 EDT
Why was this bug marked as duplicate?
It is not the duplicate of bug 971001 as it has completely different symptoms at different time (this is rules compile time problem).

Marking this reopened as it is not fixed in BRMS 6.0.0.ER2.
Comment 4 Mario Fusco 2013-09-30 03:47:03 EDT
Tomas, I wanted to reproduce this issue but I couldn't find that testMatchesOperator you mentioned in your first comment. Where is it?
Comment 5 Tomas Schlosser 2013-09-30 08:33:02 EDT
Hi Mario,
check the pull request #208 in drools repository. It was closed, but it seems the tests were never used. Have a look there and merge the tests, please.

https://github.com/droolsjbpm/drools/pull/208
Comment 6 Mario Fusco 2013-10-03 08:47:58 EDT
It was a mvel bug that I fixed here https://github.com/mvel/mvel/commit/8e54d02ed8f7f75ee51f5057dedb99c063040691

The fix will be available with the next mvel release (that I will drop asap).
Comment 10 Tomas Schlosser 2013-12-10 15:06:32 EST
Verified in BRMS-6.0.0 ER5.

Note You need to log in before you can comment on or make changes to this bug.