Bug 971070 - [RHSC] Peer Probe does not result in a related event message in RHSC
[RHSC] Peer Probe does not result in a related event message in RHSC
Status: CLOSED DUPLICATE of bug 910698
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Shubhendu Tripathi
Matt Mahoney
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 11:22 EDT by Matt Mahoney
Modified: 2015-05-12 14:30 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-23 07:11:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Mahoney 2013-06-05 11:22:51 EDT
Description of problem:
When doing a peer probe via Gluster CLI, the probe is successful, but a related event message is not generated in the Console. Thus, the user may not know that there is a new server available to import.

Note, the new server is available to import (via cluster.general) even thought there is no event message indicating so.

Version-Release number of selected component (if applicable):
bb2

How reproducible:


Steps to Reproduce:
1. Add one or more servers via Console
2. From Gluster cli, peer probe a server that is not yet a member of the cluster
3. In console, Monitor Event messages

Actual results:


Expected results:
An event message should be generated when a server is available to import.

Additional info:
Comment 2 Shubhendu Tripathi 2013-06-24 00:53:18 EDT
Hi Matt,

When there is a successful peer probe from CLI, in UI there is an action populated which says "Some new hosts are detected in the cluster. You can Import them to engine or Detach them from the cluster".

Yes there is no event log message regarding the same. We feel the action message is more prominent and has intimation regarding the newly available hosts for import/detach. The event log message can be added but the same would keep flashing every 5 seconds in the event log section till the host if either imported or detached to/from the cluster.

Let us know if still we need the event log message for the same. We can get the same enabled.
Comment 3 Shubhendu Tripathi 2013-07-02 04:23:54 EDT
Hi Matt,

Kindly provide your comments.
Comment 5 Sahina Bose 2013-07-31 07:00:38 EDT
Will show an alert (similar to pm alerts) on the cluster table (in main tab)
Comment 6 Scott Haines 2013-09-23 19:18:58 EDT
Retargeting for 2.1.z U2 (Corbett) release.
Comment 7 Sahina Bose 2015-01-23 07:11:41 EST

*** This bug has been marked as a duplicate of bug 910698 ***

Note You need to log in before you can comment on or make changes to this bug.