Bug 971120 - oo-accept-node should detect gears without cartridge directories
oo-accept-node should detect gears without cartridge directories
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 14:13 EDT by Paul Morie
Modified: 2015-05-14 19:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:54:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morie 2013-06-05 14:13:50 EDT
Currently the oo-admin-accept-node tool does not check to see whether each gear has a cartridge directory or not.  A gear without a cartridge dir should be a validation failure.
Comment 1 Paul Morie 2013-06-11 18:06:09 EDT
PR submitted to master.
Comment 2 Paul Morie 2013-06-12 18:26:31 EDT
PR failed because of accept-node failures.  I've found also that devenv test does not create the cucumber log.
Comment 3 Paul Morie 2013-06-18 13:28:49 EDT
Another change that should happen for this bug is that the cartridge migration should fail if a gear has no cartridges.
Comment 4 Xiaoli Tian 2013-06-19 05:31:47 EDT
Since there's more change coming for this bug, move it back to ASSIGNED in case it's missed from the filter list
Comment 5 openshift-github-bot 2013-07-31 15:20:11 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/028b0ec151c77e5dfcf525282798d407cf6e980d
Bug 971120: remove node.feature and online_node_steps.rb
Comment 6 openshift-github-bot 2013-07-31 15:20:19 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/6cfb9c204a4d8bfb8a0edfede9bc9b34fbd4cc3d
Bug 971120: refactor openshift-node.feature
Comment 7 Meng Bo 2013-08-01 06:54:23 EDT
Hi Paul,

Any code change for this bug? Seems the two PRs only for the unit test.

And checked on devenv-stage_429.

The issue still can be reproduced.
Comment 8 Paul Morie 2013-08-01 10:15:36 EDT
Bo Meng-

Hahaha.  I had a lot of trouble with the cucumber tests and actually started over trying to get the changes to the cuke tests to work.  I must have forgotten to actually make the change in oo-accept-node.

Thanks,

P
Comment 9 openshift-github-bot 2013-08-01 12:07:12 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/c996164f7df12880e774011bcd442cf3362dc809
Fix bug 971120: add empty gear check for oo-accept-node
Comment 10 openshift-github-bot 2013-08-01 13:20:56 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/9d59520165e119a6a55b8b9d4b2a64305e875a57
Bug 971120: remove node.feature and online_node_steps.rb
Comment 11 Meng Bo 2013-08-02 04:32:32 EDT
Checked on devenv_3604, issue fixed.

# oo-accept-node -v
INFO: loading node configuration file /etc/openshift/node.conf
INFO: loading resource limit file /etc/openshift/resource_limits.conf
INFO: finding external network device
INFO: checking node public hostname resolution
INFO: checking selinux status
INFO: checking selinux openshift-hosted policy
INFO: checking selinux booleans
INFO: checking selinux nodes
INFO: checking package list
INFO: checking services
INFO: checking kernel semaphores >= 512
INFO: checking cgroups configuration
INFO: checking cgroups processes
INFO: checking presence of tc qdisc
INFO: checking for cgroup filter
INFO: checking presence of tc classes
INFO: checking filesystem quotas
INFO: checking quota db file selinux label
INFO: checking 2 user accounts
INFO: checking application dirs
FAIL: directory 604176745706929942167552 doesn't have a cartridge directory
INFO: checking system httpd configs
INFO: checking cartridge repository
1 ERRORS

Note You need to log in before you can comment on or make changes to this bug.