Bug 971195 - RFE - Either change the "Successful Save" message to a HTML message inside a div, or add a "Close" button so that the page can be easily closed.
RFE - Either change the "Successful Save" message to a HTML message inside a ...
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity low
: ---
: 1.3
Assigned To: Matthew Casperson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-05 20:59 EDT by Misty Stanley-Jones
Modified: 2014-08-04 18:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 17:16:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of formatting (8.16 KB, image/png)
2013-11-24 19:24 EST, Lee Newson
no flags Details

  None (edit)
Description Misty Stanley-Jones 2013-06-05 20:59:01 EDT
$SUBJECT - because if I want to save and close, it currently takes two clicks. I know it's a first-world problem, but there it is. I think you could put the "Saved" message up in the black part of the header. Maybe if it is an error message, still pop it up so that it is more obvious.
Comment 1 Lee Newson 2013-10-01 01:16:59 EDT
Moving this back to NEW, since there hasn't been any activity on this bug for
some time and we currently don't have anything scheduled.
Comment 2 Matthew Casperson 2013-11-17 18:36:46 EST
Fixed in 201311180926

This can be verified on the dev server.
Comment 3 Matthew Casperson 2013-11-24 18:10:21 EST
Moving back to assigned - I need to add this to the content spec UI.
Comment 4 Matthew Casperson 2013-11-24 19:13:34 EST
Fixed in 201311251000

All instances of Window.alert have been removed, except for the global uncaught exception handler.

This can be verified on the dev server.
Comment 5 Lee Newson 2013-11-24 19:24:07 EST
Created attachment 828462 [details]
Example of formatting

Verified that the Window.alert calls have been replaced by divs, however the new lines in the error messages are no longer being preserved (see the attached screenshot).

I also think that the text in the button should be centre aligned.
Comment 6 Matthew Casperson 2013-11-24 23:28:16 EST
Libne breaks are now preserved in the alert box.
Comment 7 Matthew Casperson 2013-11-25 00:08:47 EST
All pushbuttons now center text horizontally. This makes no difference for most buttons, which are only as wide as they need to be anyway. It does make some of the larger UI buttons look a bit better IMHO, and centers the OK text in the alert dialog.
Comment 8 Lee Newson 2013-11-25 01:06:21 EST
Verified that the new lines are now preserved, however the centre change has made a few other minor UX issues.

The issue is that the toggle states haven't been updated as well so you get a reasonable amount of flickering when switch tabs for example. Personally I probably prefer the centre alignment for all buttons as well, so we probably just need to update the css rule for the toggle states.
Comment 9 Lee Newson 2013-11-25 01:09:17 EST
Forgot to mention that I'm moving it back to ASSIGNED since the toggle button states used to be exactly the same except for the colour, so I classed it as a regression. If you don't see it as an issue Matt, then feel free to move it to VERIFIED.
Comment 10 Matthew Casperson 2013-11-25 01:26:47 EST
The toggle states are now centered as well.

Note You need to log in before you can comment on or make changes to this bug.