Bug 971254 - [abrt] mate-control-center-1.5.5-3.fc18: __strcmp_sse4_2: Process /usr/bin/mate-keybinding-properties was killed by signal 11 (SIGSEGV)
[abrt] mate-control-center-1.5.5-3.fc18: __strcmp_sse4_2: Process /usr/bin/ma...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mate-control-center (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
abrt_hash:09b47abfc871452862d7302d45a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 02:38 EDT by zodiac8765+rh
Modified: 2013-06-29 13:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 13:26:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (30.21 KB, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: cgroup (133 bytes, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: core_backtrace (878 bytes, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: dso_list (8.84 KB, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: environ (1.65 KB, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: maps (27.75 KB, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: open_fds (398 bytes, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: proc_pid_status (792 bytes, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details
File: var_log_messages (810 bytes, text/plain)
2013-06-06 02:39 EDT, zodiac8765+rh
no flags Details

  None (edit)
Description zodiac8765+rh 2013-06-06 02:38:56 EDT
Version-Release number of selected component:
mate-control-center-1.5.5-3.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        mate-keybinding-properties
crash_function: __strcmp_sse4_2
executable:     /usr/bin/mate-keybinding-properties
kernel:         3.9.4-200.fc18.i686
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (8 frames)
 #0 __strcmp_sse4_2 at ../sysdeps/i386/i686/multiarch/strcmp-sse4.S:250
 #1 g_strcmp0 at gtestutils.c:1992
 #2 key_match at mate-keybinding-properties.c:459
 #3 gtk_tree_model_foreach_helper at gtktreemodel.c:1607
 #5 gtk_tree_model_foreach at gtktreemodel.c:1653
 #6 append_keys_to_tree at mate-keybinding-properties.c:477
 #7 reload_key_entries at mate-keybinding-properties.c:1028
 #8 setup_dialog at mate-keybinding-properties.c:1904
Comment 1 zodiac8765+rh 2013-06-06 02:39:09 EDT
Created attachment 757492 [details]
File: backtrace
Comment 2 zodiac8765+rh 2013-06-06 02:39:14 EDT
Created attachment 757493 [details]
File: cgroup
Comment 3 zodiac8765+rh 2013-06-06 02:39:20 EDT
Created attachment 757494 [details]
File: core_backtrace
Comment 4 zodiac8765+rh 2013-06-06 02:39:26 EDT
Created attachment 757495 [details]
File: dso_list
Comment 5 zodiac8765+rh 2013-06-06 02:39:31 EDT
Created attachment 757496 [details]
File: environ
Comment 6 zodiac8765+rh 2013-06-06 02:39:35 EDT
Created attachment 757497 [details]
File: limits
Comment 7 zodiac8765+rh 2013-06-06 02:39:40 EDT
Created attachment 757498 [details]
File: maps
Comment 8 zodiac8765+rh 2013-06-06 02:39:45 EDT
Created attachment 757499 [details]
File: open_fds
Comment 9 zodiac8765+rh 2013-06-06 02:39:50 EDT
Created attachment 757500 [details]
File: proc_pid_status
Comment 10 zodiac8765+rh 2013-06-06 02:39:53 EDT
Created attachment 757501 [details]
File: var_log_messages
Comment 11 Wolfgang Ulbrich 2013-06-29 08:51:17 EDT
Can you describe a little more detailed what's happend?
Does this error ocours frequently?
Comment 12 zodiac8765+rh 2013-06-29 12:34:31 EDT
(In reply to Wolfgang Ulbrich from comment #11)
> Can you describe a little more detailed what's happend?
> Does this error ocours frequently?

I just Customize my own keybinding:
1. on Lenovo notebook T430,there is a key One-key-buckup(Windows?).I bind it to "/bin/xset dpms force off".
2. maybe some command on "Fn+F3/F4/F5..".I can not remember.

Now,every time I run the mate-keybinding-properties via System->KeyBinding(Or similar) non-root.
as root, it is run OK.

I think this error may be caused by a particular set of keys cause.
Comment 13 Wolfgang Ulbrich 2013-06-29 13:26:27 EDT
Glad to hear that the issue doesn't ocours anymore with latest updates.
Upstream did a lot of fixes since 1.5.x, also libmatekbd is improved.
So i will close this report, feel free to report again if the issue still exists,
i will re-open then the report.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.