Bug 971308 - Support HTTP for kernel and initrd paths
Support HTTP for kernel and initrd paths
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ján Tomko
lijuan men
:
Depends On: 1201198
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 05:10 EDT by Guohua Ouyang
Modified: 2017-10-17 11:20 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1201198 (view as bug list)
Environment:
Last Closed: 2017-10-17 11:20:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Michal Skrivanek 2013-06-07 03:18:37 EDT
so we can change the bug title to a request for support of http paths in libvirt, if reporter agrees?
Comment 10 Ján Tomko 2013-06-24 09:01:15 EDT
Unfortunately this won't be trivial to implement in libvirt, since QEMU doesn't support http paths.

With SELinux enabled, it's libvirt that fails trying to label the image.
But if it's disabled, QEMU fails with this error:
qemu: could not load kernel 'http://127.0.0.1/kernel': No such file or directory
Comment 17 Jiri Denemark 2014-04-04 17:37:44 EDT
This bug was not selected to be addressed in Red Hat Enterprise Linux 6. We will look at it again within the Red Hat Enterprise Linux 7 product.
Comment 19 Giuseppe Scrivano 2014-09-17 11:14:05 EDT
per comment 10, should this bug be cloned to QEMU?
Comment 25 Ján Tomko 2017-10-17 11:20:13 EDT
This has been open for years and there does not seem to be much demand for it.

Note You need to log in before you can comment on or make changes to this bug.