Bug 97136 - When installing new kernel on dell poweredge 1600 SC dual xeon, initrd creation is buggy and server fails to load with new kernel
When installing new kernel on dell poweredge 1600 SC dual xeon, initrd creati...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-10 15:09 EDT by Patrick Smith
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-11 19:08:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working initrd (231.65 KB, application/octet-stream)
2003-06-11 03:29 EDT, Patrick Smith
no flags Details
the initrd that does not work (208.05 KB, application/octet-stream)
2003-06-11 03:32 EDT, Patrick Smith
no flags Details

  None (edit)
Description Patrick Smith 2003-06-10 15:09:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 
1.1.4322)

Description of problem:
When I try to upgrade the kernel to anything past 2.4.18-27.xsmp on the Dell 
PowerEdge 1600 SC dual xeon, with LSI Logic SCSI adapter, the server boots up 
with this:

ERROR: /bin/insmod exited abnormally
mount: error 6 mounting ext3
pivotroot: pivort_root(/sysroot,/sysroot/initrd) failed: 2

This is after listing a slew of errors with the mptibase module ( for the scsi 
adapter ) 

It appears the initrd is the culprit and repairing the initrd fixes the issue, 
however, we have approximately 800 of these servers that belong to customers, 
who do not want to have to workaround everytime they upgrade, this is the 
second kernel we've had the issue with. Initially the problem was non-existant, 
we installed RedHat 7.3, updated to all the latest RPMs and everything was 
well, this didnt start occurring until the latest kernel releases.

Version-Release number of selected component (if applicable):
2.4.20-18.7smp

How reproducible:
Always

Steps to Reproduce:
1. Install new kernel-2.4.20-18.7smp
2. update lilo
3. reboot
    

Actual Results:  The same listed in the description

Expected Results:  The server should have booted and mounted the root directory

Additional info:
Comment 1 Jeremy Katz 2003-06-10 16:13:08 EDT
What did you have to do to "repair the initrd"?
Comment 2 Patrick Smith 2003-06-10 17:17:56 EDT
We ended up taking the initrd from another xeon server that the install worked 
on, so we didnt directly make any repairs to it ourselves, though we did fidget 
with the linuxrc with no success.
Comment 3 Jeremy Katz 2003-06-10 18:32:26 EDT
Can you attach both a working and a non-working initrd as well as the
/etc/modules.conf and /etc/fstabs from both sets of machines?
Comment 4 Patrick Smith 2003-06-11 03:29:11 EDT
Created attachment 92335 [details]
working initrd
Comment 5 Patrick Smith 2003-06-11 03:32:17 EDT
Created attachment 92336 [details]
the initrd that does not work
Comment 6 Patrick Smith 2003-06-11 03:34:08 EDT
Below are the contents of the modules.conf and fstab from both the working and 
non working systems.

working 2.4.20-18.7smp

[root@plain root]# cat /etc/modules.conf
alias eth0 e1000
alias scsi_hostadapter mptscsih
alias usb-controller usb-ohci
[root@plain root]#
[root@plain root]# cat /etc/fstab
/dev/sda3       /       ext3    usrquota,grpquota,defaults 1 1
/dev/sda1       /boot   ext3    defaults 1 2
none    /dev/pts devpts gid=5,mode=620 0 0
none    /proc   proc    defaults 0 0
none    /dev/shm tmpfs  defaults 0 0
/dev/sda2       swap    swap    defaults 0 0
/dev/fd0   /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0 
0
[root@plain root]#


not working 2.4.20-18.7smp

root@plain [~]# cat /etc/modules.conf
alias eth0 e1000
alias scsi_hostadapter mptscsih
alias usb-controller usb-ohci
root@plain [~]#
root@plain [~]# cat /etc/fstab
/dev/sda3       /       ext3    defaults 1 1
/dev/sda1       /boot   ext3    defaults 1 2
none    /dev/pts devpts gid=5,mode=620 0 0
none    /proc   proc    defaults 0 0
none    /dev/shm tmpfs  defaults 0 0
/dev/sda2       swap    swap    defaults 0 0
/dev/fd0   /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0 
0
/dev/sdb1               /home2          ext2    defaults        0 0
root@plain [~]#
Comment 7 Jeremy Katz 2003-06-11 19:08:05 EDT
The mkinitrd as shipped in Red Hat Linux 7.3 won't work with mptscsi (at least,
as  shipped).  mptfusion support was added in Red Hat Linux 8.0.  So you should
be able to update to a newer mkinitrd to work around it.
Comment 8 Patrick Smith 2003-06-11 19:17:39 EDT
We will gave that a shot, however RH 7.3 by default did work fine with these 
boxes in particular, we were even able to install the latest update kernel 
when we first deployed them without issue. Just a side note.

Note You need to log in before you can comment on or make changes to this bug.