Bug 971382 - SELinux is preventing /usr/bin/gnome-keyring-daemon from read, open access on the file /usr/bin/gnome-keyring-daemon.
SELinux is preventing /usr/bin/gnome-keyring-daemon from read, open access on...
Status: CLOSED DUPLICATE of bug 964954
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5b38f60419a786200f273987b68...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 07:45 EDT by Moritz Baumann
Modified: 2013-06-14 02:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 02:21:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Baumann 2013-06-06 07:45:37 EDT
Description of problem:
SELinux is preventing /usr/bin/gnome-keyring-daemon from read, open access on the file /usr/bin/gnome-keyring-daemon.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that gnome-keyring-daemon should be allowed read open access on the gnome-keyring-daemon file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-keyring-d /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:gkeyringd_exec_t:s0
Target Objects                /usr/bin/gnome-keyring-daemon [ file ]
Source                        gnome-keyring-d
Source Path                   /usr/bin/gnome-keyring-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-keyring-3.6.3-1.fc18.x86_64
Target RPM Packages           gnome-keyring-3.6.3-1.fc18.x86_64
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-06-03 15:38:19 CEST
Last Seen                     2013-06-03 15:38:19 CEST
Local ID                      de00db4c-114e-497a-80e0-9ac3359be920

Raw Audit Messages
type=AVC msg=audit(1370266699.670:449): avc:  denied  { read open } for  pid=4278 comm="dbus-daemon" path="/usr/bin/gnome-keyring-daemon" dev="dm-1" ino=151150 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gkeyringd_exec_t:s0 tclass=file


type=AVC msg=audit(1370266699.670:449): avc:  denied  { execute_no_trans } for  pid=4278 comm="dbus-daemon" path="/usr/bin/gnome-keyring-daemon" dev="dm-1" ino=151150 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gkeyringd_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1370266699.670:449): arch=x86_64 syscall=execve success=yes exit=0 a0=1546e80 a1=1546de0 a2=1546f60 a3=7fa37cdc0ad0 items=0 ppid=4277 pid=4278 auid=42 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=4 tty=(none) comm=gnome-keyring-d exe=/usr/bin/gnome-keyring-daemon subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: gnome-keyring-d,xdm_dbusd_t,gkeyringd_exec_t,file,read,open

audit2allow

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t gkeyringd_exec_t:file { read open execute_no_trans };

audit2allow -R
require {
	type xdm_dbusd_t;
}

#============= xdm_dbusd_t ==============
gnome_exec_keyringd(xdm_dbusd_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-14 02:21:44 EDT

*** This bug has been marked as a duplicate of bug 964954 ***

Note You need to log in before you can comment on or make changes to this bug.