Bug 971444 - Blank non-existent spaces when using full justification in Writer
Blank non-existent spaces when using full justification in Writer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 10:20 EDT by Boricua
Modified: 2013-06-08 11:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 11:43:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Document showing the problem (320.41 KB, application/pdf)
2013-06-06 10:20 EDT, Boricua
no flags Details
Native Writer document (28.58 KB, application/vnd.oasis.opendocument.text)
2013-06-06 10:21 EDT, Boricua
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 65357 None None None Never

  None (edit)
Description Boricua 2013-06-06 10:20:41 EDT
Created attachment 757699 [details]
Document showing the problem

Description of problem:
Since the update to Libreoffice 4.1.0.0.beta1 in Fedora 19, I am having a display issue, consisting in a non-existent separation between the last letters from some words and the rest of said words (as an example, seen "developmen t" instead of "development"). Another display distortion I'm finding is superscript letters being converted to subscript.

Version-Release number of selected component (if applicable):
Libreoffice 4.1.0.0.beta1

How reproducible:
Every time I open a document.

Steps to Reproduce:
1.Start Writer
2.Open a document
3.

Actual results:
Blank spacers in words and subscript instead of superscript.

Expected results:
Normal-looking document with full justification.

Additional info:
I filed a bug report in Libreoffice, but they ruled-out an issue with the program itself.  See https://bugs.freedesktop.org/show_bug.cgi?id=65357.
I am attaching a .pdf marked example with the issue, as well as a document in .odf format.
Comment 1 Boricua 2013-06-06 10:21:53 EDT
Created attachment 757702 [details]
Native Writer document
Comment 2 Caolan McNamara 2013-06-07 05:20:41 EDT
I've a feeling that this is fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=736adbb4687eaa6b6a7a350a6452df2eceaad960 and will be good in beta2
Comment 3 Boricua 2013-06-07 09:13:02 EDT
Excellent news. I'll report back as soon as I get that update.
Meanwhile, I wish to add that I just installed 4.1.0.0-6.beta1 and Libreoffice now fails to start. Not sure it is really related to this bug.
Comment 4 David Tardon 2013-06-07 09:27:05 EDT
It is not; it has been broken by harfbuzz update.
Comment 5 Boricua 2013-06-08 09:18:27 EDT
Ok, thanks David. I just updated to 4.1.0.0-7.beta1 and all issues are gone, both display and crash. I suggest this bug may be closed for good.

Note You need to log in before you can comment on or make changes to this bug.