Bug 971458 - [RHSC] Adding Anshi node to a cluster via the Console fails for the first time, and then on re-install, the node comes UP
[RHSC] Adding Anshi node to a cluster via the Console fails for the first tim...
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Timothy Asir
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 10:59 EDT by Shruti Sampat
Modified: 2013-06-19 03:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-19 03:24:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (800.98 KB, text/x-log)
2013-06-06 11:03 EDT, Shruti Sampat
no flags Details
host deploy logs 1 (160.02 KB, text/x-log)
2013-06-06 11:09 EDT, Shruti Sampat
no flags Details
host deploy logs 2 (145.19 KB, text/x-log)
2013-06-06 11:10 EDT, Shruti Sampat
no flags Details
vdsm logs (2.96 MB, text/x-log)
2013-06-06 11:13 EDT, Shruti Sampat
no flags Details
vdsm logs before reinstall (4.82 MB, text/x-log)
2013-06-12 06:26 EDT, Shruti Sampat
no flags Details
vdsm logs after reinstall (4.89 MB, text/x-log)
2013-06-12 06:27 EDT, Shruti Sampat
no flags Details

  None (edit)
Description Shruti Sampat 2013-06-06 10:59:17 EDT
Description of problem:
---------------------------------------
On adding a node (RHS Anshi) to a 3.1 cluster via the Console, fails for the first time, causing the host to go to 'Install Failed' state. Then on trying to re-install, the host comes UP.

This behavior was seen after an attempt to import an existing gluster cluster too.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb2.el6rhs
glusterfs version on node: glusterfs 3.3.0.10rhs
vdsm version: vdsm-4.9.6-23.el6rhs.x86_64 

How reproducible:
Intermittent

Steps to Reproduce:
1. Try to add a host to a 3.1 cluster via the Console.
2. Host after bootstrap, goes to 'Install Failed' state.
3. Click on re-install on the General tab for the particular host.

Actual results:
The host comes UP now.

Expected results:
The host should come up the first time after bootstrap.

Additional info:
Comment 1 Shruti Sampat 2013-06-06 11:03:33 EDT
Created attachment 757719 [details]
engine logs
Comment 2 Shruti Sampat 2013-06-06 11:09:16 EDT
Created attachment 757720 [details]
host deploy logs 1
Comment 3 Shruti Sampat 2013-06-06 11:10:54 EDT
Created attachment 757722 [details]
host deploy logs 2
Comment 5 Shruti Sampat 2013-06-06 11:13:55 EDT
Created attachment 757725 [details]
vdsm logs
Comment 6 Timothy Asir 2013-06-10 08:46:08 EDT
Could you provide me the following details/files from the node
before and after re-install.
~~~~~~     ~~~~~

   i)   /etc/vdsm/vdsm.conf,
   ii)  log files,
   iii) the output of "rpm -qa | grep vdsm" and
   iv)  the output of "service vdsmd status"
Comment 7 Shruti Sampat 2013-06-12 06:25:41 EDT
Before reinstall - 

[root@rhs-new-anshi2 ~]# cat /etc/vdsm/vdsm.conf
[addresses]
management_port = 54321

[vars]
ssl = true

[root@rhs-new-anshi2 ~]# rpm -qa|grep vdsm
vdsm-python-4.9.6-23.el6rhs.x86_64
vdsm-debug-plugin-4.9.6-23.el6rhs.noarch
vdsm-debuginfo-4.9.6-23.el6rhs.x86_64
vdsm-cli-4.9.6-23.el6rhs.noarch
vdsm-gluster-4.9.6-23.el6rhs.noarch
vdsm-reg-4.9.6-23.el6rhs.noarch
vdsm-4.9.6-23.el6rhs.x86_64
vdsm-hook-faqemu-4.9.6-23.el6rhs.noarch

[root@rhs-new-anshi2 ~]# service vdsmd status
VDS daemon server is running

After reinstall - 

[root@rhs-new-anshi2 ~]# cat /etc/vdsm/vdsm.conf 
[addresses]
management_port = 54321

[vars]
ssl = true

[root@rhs-new-anshi2 ~]# rpm -qa|grep vdsm
vdsm-python-4.9.6-23.el6rhs.x86_64
vdsm-debug-plugin-4.9.6-23.el6rhs.noarch
vdsm-debuginfo-4.9.6-23.el6rhs.x86_64
vdsm-cli-4.9.6-23.el6rhs.noarch
vdsm-gluster-4.9.6-23.el6rhs.noarch
vdsm-reg-4.9.6-23.el6rhs.noarch
vdsm-4.9.6-23.el6rhs.x86_64
vdsm-hook-faqemu-4.9.6-23.el6rhs.noarch

[root@rhs-new-anshi2 ~]# service vdsmd status
VDS daemon server is running
Comment 8 Shruti Sampat 2013-06-12 06:26:42 EDT
Created attachment 760083 [details]
vdsm logs before reinstall
Comment 9 Shruti Sampat 2013-06-12 06:27:57 EDT
Created attachment 760085 [details]
vdsm logs after reinstall
Comment 10 Sahina Bose 2013-06-19 03:24:31 EDT
Unable to reproduce this issue. So closing as WORKSFORME. Please reopen if issue arises again

Note You need to log in before you can comment on or make changes to this bug.