Bug 971464 - thunderbird continually crashes (bad since today 2013-06-06, with latest updates) like a parrot pining for the fjords
thunderbird continually crashes (bad since today 2013-06-06, with latest upda...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Regression
: 981965 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 11:15 EDT by David Tonhofer
Modified: 2014-02-05 16:42 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 16:42:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (140.50 KB, text/plain)
2013-07-28 16:44 EDT, Vladyka Zubov
no flags Details

  None (edit)
Description David Tonhofer 2013-06-06 11:15:16 EDT
Description of problem:
-----------------------

Thunderbird suddenly takes a liking to crashes

E.g.:

   Edit mail. 
   Try to attach a PDF
   CRASH

Or:

   Try to add crash viewer Thunderbird add-on from file
   CRASH

If started from console, I see:


GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(thunderbird:2180): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `GdkWindow'

(thunderbird:2180): Gdk-CRITICAL **: IA__gdk_window_get_toplevel: assertion `GDK_IS_WINDOW (window)' failed

It's good that there are assertions. :-)
It's bad that they fail :-(

Version-Release number of selected component (if applicable):
-------------------------------------------------------------

thunderbird-17.0.6-1.fc18.x86_64

How reproducible:
-----------------

   As of today, always.

Steps to Reproduce:
------------------

   Try to add crash viewer Thunderbird add-on from file
   CRASH
Comment 1 David Tonhofer 2013-06-06 11:26:17 EDT
I'm no longer fresh in gdb fiddling...

But here is some info

thunderbird:2476): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `GdkWindow'

(thunderbird:2476): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `GdkWindow'

Program received signal SIGSEGV, Segmentation fault.
0x000000396b03da60 in gdk_window_add_update_window () from /lib64/libgdk-x11-2.0.so.0
(gdb) bt
#0  0x000000396b03da60 in gdk_window_add_update_window () from /lib64/libgdk-x11-2.0.so.0
#1  0x000000396b0423b1 in gdk_window_process_all_updates () from /lib64/libgdk-x11-2.0.so.0
#2  0x000000396b042499 in gdk_window_update_idle () from /lib64/libgdk-x11-2.0.so.0
#3  0x000000396b01ebb7 in gdk_threads_dispatch () from /lib64/libgdk-x11-2.0.so.0
#4  0x0000003e20847a55 in g_main_dispatch (context=0x7fac3711f9d0) at gmain.c:2715
#5  g_main_context_dispatch (context=context@entry=0x7fac3711f9d0) at gmain.c:3219
#6  0x0000003e20847d88 in g_main_context_iterate (context=context@entry=0x7fac3711f9d0, block=block@entry=0, dispatch=dispatch@entry=1,
    self=<optimized out>) at gmain.c:3290
#7  0x0000003e20847e44 in g_main_context_iteration (context=0x7fac3711f9d0, may_block=0) at gmain.c:3351
#8  0x00007fac351bdfb8 in nsAppShell::ProcessNextNativeEvent(bool) () from /usr/lib64/thunderbird/libxul.so
#9  0x00007fac351d3fa1 in nsBaseAppShell::DoProcessNextNativeEvent(bool, unsigned int) () from /usr/lib64/thunderbird/libxul.so
#10 0x00007fac351d4068 in nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal*, bool, unsigned int) () from /usr/lib64/thunderbird/libxul.so
#11 0x00007fac355551b3 in nsThread::ProcessNextEvent(bool, bool*) () from /usr/lib64/thunderbird/libxul.so
#12 0x00007fac3552b251 in NS_ProcessNextEvent_P(nsIThread*, bool) () from /usr/lib64/thunderbird/libxul.so
#13 0x00007fac354738be in mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) () from /usr/lib64/thunderbird/libxul.so
#14 0x00007fac35573bdd in MessageLoop::Run() () from /usr/lib64/thunderbird/libxul.so
#15 0x00007fac351d3989 in nsBaseAppShell::Run() () from /usr/lib64/thunderbird/libxul.so
#16 0x00007fac350b1b8d in nsAppStartup::Run() () from /usr/lib64/thunderbird/libxul.so
#17 0x00007fac348db7e2 in XREMain::XRE_mainRun() () from /usr/lib64/thunderbird/libxul.so
#18 0x00007fac348db9d4 in XREMain::XRE_main(int, char**, nsXREAppData const*) () from /usr/lib64/thunderbird/libxul.so
#19 0x00007fac348dbc10 in XRE_main () from /usr/lib64/thunderbird/libxul.so
#20 0x00000000004022f4 in main ()
Comment 2 Jan Horak 2013-06-07 04:19:03 EDT
Thanks for bugreport. Do you actually get crash when in file open dialog? Please look to Help/Troubleshooting information/about:crashes and send us links to latest crashes. Thanks.
Comment 3 David Tonhofer 2013-06-07 04:36:44 EDT
Thanks.

I find this in about:crashes, all submitted yesterday:

bp-15463024-44d6-4d5b-9c75-e12aa2130606
1b6577f1-ff44-c1f6-00873950-23859dfb
bp-5d192f30-4cfe-456a-b863-d700f2130606
bp-51d06069-0349-4039-8bfb-affeb2130606
bp-64a40791-5ba9-4035-9d18-611ff2130606
bp-6c1101aa-f548-42a4-bf16-363542130606
bp-cfd8726e-f463-4ca1-91ae-8e17f2130606

https://crash-stats.mozilla.com/report/index/bp-15463024-44d6-4d5b-9c75-e12aa2130606

I actually got the crash immediately confirming the attachment in the open file dialog.

Just retested, doesn't re-occur at this moment. This is a laptop, so the machine was rebooted in the meantime :-(

I know that I rebooted it after yum update though, so it's not some inconsistent library load.
Comment 4 Jan Horak 2013-06-07 04:50:02 EDT
Hm, this might be regression introduced by gtk2-2.24.18-1.fc18.  If you are able to reproduce it again, try then with downgraded gtk2 package.
Comment 5 David Tonhofer 2013-06-17 05:08:14 EDT
Another one today; haven't tried with downgraded packages yet.

https://crash-stats.mozilla.com/report/index/bp-9bdd666a-be6a-4569-8991-bca782130617

This occurs if I have a mail ready-to-be-sent, with e-mail recipient filled in and I want to add a PDF. Select PDF in the file selection dialog. Click OPEN. Crash. This is actually reproducible.
Comment 6 BeGe 2013-07-04 11:21:38 EDT
I had the same crash problem when attaching a file to TB (Fedora 18, TB 17.0.7 and GTK2-2.24.19-1). I downgraded to  GTK2-2.24.16-1 and it works fine now for one day with several attach.
Thanks Jan, the workaround is fine.
Comment 7 Jan Horak 2013-07-08 03:00:27 EDT
Lets switch to gtk2 component.
Comment 8 Jan Horak 2013-07-08 03:19:36 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=981965 might be also related.
Comment 9 Jan Horak 2013-07-08 05:18:43 EDT
*** Bug 981965 has been marked as a duplicate of this bug. ***
Comment 10 David Tonhofer 2013-07-16 07:39:21 EDT
Grrr....

# yum downgrade gtk2

Resolving Dependencies
--> Running transaction check
---> Package gtk2.i686 0:2.24.13-1.fc18 will be a downgrade
---> Package gtk2.x86_64 0:2.24.13-1.fc18 will be a downgrade
---> Package gtk2.i686 0:2.24.19-1.fc18 will be erased
---> Package gtk2.x86_64 0:2.24.19-1.fc18 will be erased
--> Finished Dependency Resolution

Downgrading:
 gtk2                    i686                      2.24.13-1.fc18
 gtk2                    x86_64                    2.24.13-1.fc18

Is this ok [y/N]: y

Complete!



Yes, Thunderbird does not crash now.
Comment 11 David V 2013-07-25 14:05:59 EDT
Any fix if I can't downgrade gtk2?  I get the following dependency problems.  I can remove the immodule fine, but if I try to remove the adwaita-gtk2-theme, yum wants to remove gnome-shell, nautilus, and other important packages...

--> Running transaction check
---> Package gtk2.i686 0:2.24.13-1.fc18 will be a downgrade
---> Package gtk2.x86_64 0:2.24.13-1.fc18 will be a downgrade
---> Package gtk2.i686 0:2.24.19-1.fc18 will be erased
---> Package gtk2.x86_64 0:2.24.19-1.fc18 will be erased
--> Finished Dependency Resolution
Error: Package: gtk2-immodule-xim-2.24.19-1.fc18.x86_64 (@updates)
           Requires: gtk2 = 2.24.19-1.fc18
           Removing: gtk2-2.24.19-1.fc18.i686 (@updates)
               gtk2 = 2.24.19-1.fc18
           Downgraded By: gtk2-2.24.13-1.fc18.i686 (fedora)
               gtk2 = 2.24.13-1.fc18
Error: Package: adwaita-gtk2-theme-3.6.5-1.fc18.x86_64 (@updates)
           Requires: gtk2(x86-64) >= 2.24.15
           Removing: gtk2-2.24.19-1.fc18.x86_64 (@updates)
               gtk2(x86-64) = 2.24.19-1.fc18
           Downgraded By: gtk2-2.24.13-1.fc18.x86_64 (fedora)
               gtk2(x86-64) = 2.24.13-1.fc18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 12 David Tonhofer 2013-07-25 18:13:30 EDT
Can you downgrade all those packages in a single command?
Comment 13 David V 2013-07-25 18:30:03 EDT
No, I tried that too but then other dependencies showed up.  Instead I deleted the adwaita-gtk2-theme without dependencies by using

rpm -e --nodeps adwaita-gtk2-theme

and I was able to downgrade gtk2 and Thunderbird no longer crashes.
Comment 14 Matthias Clasen 2013-07-25 19:12:35 EDT
Can't reproduce the crash here, with gtk2 2.24.20 in f19
Comment 15 Vladyka Zubov 2013-07-28 16:44:40 EDT
I attached attachment
then crash

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/lib64/seamonkey/seamonkey
core_backtrace: 
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib64/seamonkey/seamonkey
kernel:         3.9.10-200.fc18.x86_64
package:        seamonkey-2.19-1.fc18
reason:         Process /usr/lib64/seamonkey/seamonkey was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:
Comment 16 Vladyka Zubov 2013-07-28 16:44:47 EDT
Created attachment 779447 [details]
File: backtrace
Comment 17 David Tonhofer 2013-08-13 03:22:19 EDT
Quite likely the same:

https://bugzilla.mozilla.org/show_bug.cgi?id=902397
Comment 18 David Tonhofer 2013-08-13 03:44:55 EDT
Now running

"thunderbird-17.0.7-1.fc18.x86_64"

since July 1, apparently

and still

"gtk2-2.24.19-1.fc18"

but I down a "yum update" today, and I currently cannot reproduce the crash. Hmmm.

According to the /var/log/yum.log (the rpm database sadly is historyless), today the following got updated (gtk2 got updated because I downgraded it):

Aug 13 09:28:36 Updated: 1:libreoffice-ure-3.6.7.2-3.fc18.x86_64
Aug 13 09:28:37 Updated: 1:qt-4.8.5-6.fc18.1.x86_64
Aug 13 09:28:39 Updated: 1:qt-x11-4.8.5-6.fc18.1.x86_64
Aug 13 09:28:40 Updated: hunspell-1.3.2-13.fc18.x86_64
Aug 13 09:28:41 Updated: gtk2-2.24.19-1.fc18.x86_64 
Aug 13 09:28:41 Updated: 1:libreoffice-gdb-debug-support-3.6.7.2-3.fc18.x86_64
Aug 13 09:28:42 Updated: 1:libreoffice-opensymbol-fonts-3.6.7.2-3.fc18.noarch
Aug 13 09:28:44 Updated: 1:libreoffice-writer-3.6.7.2-3.fc18.x86_64
Aug 13 09:29:00 Updated: 1:libreoffice-core-3.6.7.2-3.fc18.x86_64
Aug 13 09:29:02 Updated: 1:libreoffice-presenter-screen-3.6.7.2-3.fc18.x86_64
Aug 13 09:29:02 Updated: 1:libreoffice-impress-3.6.7.2-3.fc18.x86_64
Aug 13 09:31:35 Updated: 1:libreoffice-debuginfo-3.6.7.2-3.fc18.x86_64
Aug 13 09:31:37 Updated: 1:libreoffice-calc-3.6.7.2-3.fc18.x86_64
Aug 13 09:31:39 Updated: 1:libreoffice-langpack-fr-3.6.7.2-3.fc18.x86_64
Aug 13 09:31:39 Updated: 1:libreoffice-langpack-en-3.6.7.2-3.fc18.x86_64
Aug 13 09:31:40 Updated: 1:qt-qdbusviewer-4.8.5-6.fc18.1.x86_64
Aug 13 09:31:46 Updated: 1:qt-devel-4.8.5-6.fc18.1.x86_64
Aug 13 09:31:46 Updated: 1:qt-mysql-4.8.5-6.fc18.1.x86_64
Aug 13 09:32:40 Updated: 1:qt-debuginfo-4.8.5-6.fc18.1.x86_64
Aug 13 09:32:41 Updated: kernel-headers-3.10.4-100.fc18.x86_64
Aug 13 09:32:41 Updated: lftp-4.4.8-1.fc18.x86_64
Aug 13 09:32:42 Updated: telepathy-glib-0.20.4-1.fc18.x86_64
Aug 13 09:32:43 Updated: soprano-debuginfo-2.9.3-1.fc18.x86_64
Aug 13 09:32:43 Updated: 1:make-3.82-15.fc18.x86_64
Aug 13 09:32:52 Installed: kernel-3.10.4-100.fc18.x86_64
Aug 13 09:32:53 Installed: kernel-modules-extra-3.10.4-100.fc18.x86_64
Aug 13 09:32:54 Updated: gtk2-2.24.19-1.fc18.i686
Comment 19 David Tonhofer 2013-08-16 10:47:04 EDT
In a possibly related thing, *firefox* 17.0.1 crashes consistently on posting of attachments to a JIRA application. Downgraded to gtk2-2.24.19-1. Then it works.
Comment 20 David Tonhofer 2013-08-22 12:18:54 EDT
Still crashes. Back to gtk2-2.24.13-1.fc18.
Comment 21 David Tonhofer 2013-11-05 05:56:50 EST
Still crashes with the latest thunderbird

thunderbird-24.0-3.fc18.x86_64

and

gtk2-2.24.19-1.fc18.i686
Comment 22 BeGe 2013-11-05 06:09:57 EST
If it can help. It works fine for me with:
gtk2-2.24.22-1.fc19.i686
thunderbird-24.1.0-1.fc19.i686
but i am in FC19.
Kr
Comment 23 David Tonhofer 2013-11-05 06:35:05 EST
Thanks. I wanted to give make a concerted effort to upgrade soon, so we will see,
Comment 24 Fedora End Of Life 2013-12-21 08:53:37 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 25 Fedora End Of Life 2014-02-05 16:42:27 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.