This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 971478 - Packages are not filtered along with filtered errata
Packages are not filtered along with filtered errata
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Partha Aji
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 11:49 EDT by Mike McCune
Modified: 2013-07-18 17:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:17:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-06-06 11:49:41 EDT
If you specify and includes or excludes filter on errata it will only filter the errata metadata in the target repositories but will *not* filter the associated packages.

This means if you have a repo with:

package-1.0.0
package-1.1.0

Errata1: package-1.1.0

and you filter out Errata1 the resulting filtered repo will still have:

package-1.0.0
package-1.1.0

we need to filter out the package-1.1.0 as well.

This is spun out of:

https://bugzilla.redhat.com/show_bug.cgi?id=957057
Comment 1 Partha Aji 2013-06-06 12:02:50 EDT
https://github.com/Katello/katello/pull/2437
Comment 3 Partha Aji 2013-06-06 12:39:43 EDT
What this resolution does
Given repositories with packages p1, p2  and erratum e1 with packages (p1, p2)
1) If you excluded e1, then packages p1 & p2 will get excluded from the cloned repo
2) Similarly if you included everything but e1, then packages p1 & p2 will get excluded from the cloned repo

Would recommend testing these cases with
1) Errata id based filters
2) Errata Type based filters
3) Errata date range filters.

What this fix does not do 
If you have packages in the repo that do not belong to any errata. They will get copied over even if you said I only want the packages in this errata included. Will file a bz for that and will have to fix that in the near future.
Comment 4 Brad Buckingham 2013-06-06 17:58:23 EDT
Mass move to ON_QA
Comment 5 Hayk Hovsepyan 2013-06-10 08:23:57 EDT
Verified in revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
katello-cli-1.4.2-7.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
katello-configure-1.4.3-14.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
katello-glue-elasticsearch-1.4.2-11.el6sat.noarch
katello-1.4.2-11.el6sat.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
candlepin-cert-consumer-cfseserver2.usersys.redhat.com-1.0-1.noarch
signo-0.0.16-1.el6sat.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
Katello-Katello-Installation-Satellite6Latest-1.0-8.noarch
foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.1.1-1.el6sat.noarch
foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
foreman-1.1.10005-1.noarch
foreman-postgresql-1.1.10005-1.noarch
python-ldap-2.3.10-1.el6.x86_64
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
foreman-proxy-1.1.10003-1.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-common-1.4.2-11.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-glue-candlepin-1.4.2-11.el6sat.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
katello-all-1.4.2-11.el6sat.noarch
katello-agent-1.4.2-4.el6sat.noarch
foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
signo-katello-0.0.16-1.el6sat.noarch
katello-glue-pulp-1.4.2-11.el6sat.noarch
katello-configure-foreman-1.4.3-14.el6sat.noarch
candlepin-0.8.9-1.el6_4.noarch
katello-foreman-all-1.4.2-11.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-45.noarch
foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

Now the packages of excluded erratas are not available to install for clients.
Comment 6 Mike McCune 2013-07-18 17:17:32 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.