Bug 971517 - Deploying multiple VM's results in some VM's getting 2 ip addresses
Deploying multiple VM's results in some VM's getting 2 ip addresses
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: rc
: 3.0
Assigned To: Gary Kotton
yfried
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 13:10 EDT by Gary Kotton
Modified: 2016-04-26 18:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-quantum-2013.1.2-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 13:16:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1160442 None None None Never
Red Hat Product Errata RHBA-2013:0968 normal SHIPPED_LIVE Red Hat OpenStack 3.0 ("Grizzly") bug fix and enhancement update 2013-06-27 17:14:27 EDT

  None (edit)
Description Gary Kotton 2013-06-06 13:10:59 EDT
Description of problem:
When deploying ~200 VM's some of the VM's received 2 IP addresses

Version-Release number of selected component (if applicable):


How reproducible:
76.798%


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Running the following script helps:
#!/bin/bash
COUNTER=0
for i in {1..200}
do
   (
   echo "Deploy VM vm-$i"
   nova boot --image cirros --flavor 1 vm-$i
   let COUNTER=$COUNTER+1
   if [ $COUNTER -eq 300 ]
      then
      sleep 2
      COUNTER=0
   fi
) &
done
Comment 7 Gary Kotton 2013-06-12 11:22:27 EDT
For quantum we set all to -1.
Comment 8 yfried 2013-06-19 03:34:57 EDT
could not recreate issue in older versions (openstack-quantum-2013.1.1-10.el6ost.noarch.rpm )
or on current (openstack-quantum-2013.1.2-2.el6ost) - created ~200 VMs (!100 succeeded due to resources limitations)

no multiple IPs for any of them

instances were created using --num-instances flag
Comment 10 errata-xmlrpc 2013-06-27 13:16:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0968.html

Note You need to log in before you can comment on or make changes to this bug.