Bug 971529 - Horizon shows an error page after Controller node is installed.
Summary: Horizon shows an error page after Controller node is installed.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer   
(Show other bugs)
Version: 3.0
Hardware: Unspecified Unspecified
high
high
Target Milestone: snapshot2
: 3.0
Assignee: Jordan OMara
QA Contact: Ami Jeain
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-06 18:19 UTC by Crag Wolfe
Modified: 2016-04-27 04:15 UTC (History)
3 users (show)

Fixed In Version: ruby193-openstack-foreman-installer-0.0.15-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 21:11:27 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:0939 normal SHIPPED_LIVE new package: ruby193-openstack-foreman-installer 2013-06-12 01:09:32 UTC

Description Crag Wolfe 2013-06-06 18:19:34 UTC
Description of problem:
After deploying a node as a controller node by associating it with the quickstack::controller puppet class, the horizon web server shows an error page immediately upon logging in.

How reproducible:
Every time.

Steps to Reproduce:
1.  Deploy a new controller node through the foreman UI.
2.  Log in to the Horizon dashboard on the controller node.

Actual results:
Error page is displayed.

Expected results:
An openstack dashboard is displayed.

Additional info:

I am able to get the Horizon web page to load only by deleting the keystone cinder endpoint, e.g.:
/usr/bin/keystone --token 3789f6674b5305851e1ba51cdc4cca3e --endpoint http://127.0.0.1:35357/v2.0/ endpoint-list
# delete the one with port 8776
usr/bin/keystone --token 3789f6674b5305851e1ba51cdc4cca3e --endpoint http://127.0.0.1:35357/v2.0/ endpoint-delete 7f8821476aff448f892f2b8b576daadc
More info here: http://pad.engineering.redhat.com/fm-horizon-cinder-connection-refused
Possibly same issue:
https://ask.openstack.org/question/347/why-do-i-get-connection-refused-when-reaching-openstack-dashboard/

Comment 1 Charles Crouch 2013-06-06 18:26:21 UTC
This issue has a workaround as Crag describes, so I don't see this as a blocker for snap2 or RC, but it needs to be addressed for GA.
Regardless Crag is investigating right now.

Comment 2 Charles Crouch 2013-06-10 02:03:44 UTC
IIUC Crag has this fixed and in a build

Comment 4 Jay Turner 2013-06-10 14:02:29 UTC
QA ack for inclusion in the RC.

Comment 7 errata-xmlrpc 2013-06-11 21:11:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0939.html


Note You need to log in before you can comment on or make changes to this bug.