Bug 971529 - Horizon shows an error page after Controller node is installed.
Horizon shows an error page after Controller node is installed.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: snapshot2
: 3.0
Assigned To: Jordan OMara
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 14:19 EDT by Crag Wolfe
Modified: 2016-04-27 00:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: ruby193-openstack-foreman-installer-0.0.15-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 17:11:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Crag Wolfe 2013-06-06 14:19:34 EDT
Description of problem:
After deploying a node as a controller node by associating it with the quickstack::controller puppet class, the horizon web server shows an error page immediately upon logging in.

How reproducible:
Every time.

Steps to Reproduce:
1.  Deploy a new controller node through the foreman UI.
2.  Log in to the Horizon dashboard on the controller node.

Actual results:
Error page is displayed.

Expected results:
An openstack dashboard is displayed.

Additional info:

I am able to get the Horizon web page to load only by deleting the keystone cinder endpoint, e.g.:
/usr/bin/keystone --token 3789f6674b5305851e1ba51cdc4cca3e --endpoint http://127.0.0.1:35357/v2.0/ endpoint-list
# delete the one with port 8776
usr/bin/keystone --token 3789f6674b5305851e1ba51cdc4cca3e --endpoint http://127.0.0.1:35357/v2.0/ endpoint-delete 7f8821476aff448f892f2b8b576daadc
More info here: http://pad.engineering.redhat.com/fm-horizon-cinder-connection-refused
Possibly same issue:
https://ask.openstack.org/question/347/why-do-i-get-connection-refused-when-reaching-openstack-dashboard/
Comment 1 Charles Crouch 2013-06-06 14:26:21 EDT
This issue has a workaround as Crag describes, so I don't see this as a blocker for snap2 or RC, but it needs to be addressed for GA.
Regardless Crag is investigating right now.
Comment 2 Charles Crouch 2013-06-09 22:03:44 EDT
IIUC Crag has this fixed and in a build
Comment 4 Jay Turner 2013-06-10 10:02:29 EDT
QA ack for inclusion in the RC.
Comment 7 errata-xmlrpc 2013-06-11 17:11:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0939.html

Note You need to log in before you can comment on or make changes to this bug.