Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 971569 - kio_smb: [abrt] kdelibs-4.10.4-1.fc19: strchr: Process /usr/bin/kdeinit4 was killed by signal 11 (SIGSEGV)
Summary: kio_smb: [abrt] kdelibs-4.10.4-1.fc19: strchr: Process /usr/bin/kdeinit4 was ...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4281b1dd02700f1c54f36c2f9be...
: 971751 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-06 20:17 UTC by Colin J Thomson
Modified: 2013-07-01 13:56 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-01 13:56:30 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (27.45 KB, text/plain)
2013-06-06 20:17 UTC, Colin J Thomson
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-06 20:17 UTC, Colin J Thomson
no flags Details
File: core_backtrace (1.72 KB, text/plain)
2013-06-06 20:17 UTC, Colin J Thomson
no flags Details
File: dso_list (10.96 KB, text/plain)
2013-06-06 20:17 UTC, Colin J Thomson
no flags Details
File: environ (1.34 KB, text/plain)
2013-06-06 20:17 UTC, Colin J Thomson
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-06 20:17 UTC, Colin J Thomson
no flags Details
File: maps (66.41 KB, text/plain)
2013-06-06 20:18 UTC, Colin J Thomson
no flags Details
File: open_fds (148 bytes, text/plain)
2013-06-06 20:18 UTC, Colin J Thomson
no flags Details
File: proc_pid_status (925 bytes, text/plain)
2013-06-06 20:18 UTC, Colin J Thomson
no flags Details
File: var_log_messages (389 bytes, text/plain)
2013-06-06 20:18 UTC, Colin J Thomson
no flags Details

Description Colin J Thomson 2013-06-06 20:17:31 UTC
Description of problem:
I was connecting to my Laptop over the network using Dolphin.  smb://xxxx@xxx.xxx.x.x/folder/
Dolphin reported "Could not start process Unable to create io-slave:
klauncher said; Error loading 'kio_smb' and kdelibs crashed. This happens everytime.

Version-Release number of selected component:
kdelibs-4.10.4-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        'kdeinit4: kio_smb [kdeinit] smb local:/tmp/ks' '' ''
crash_function: strchr
executable:     /usr/bin/kdeinit4
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 strchr at ../sysdeps/x86_64/strchr.S:32
 #1 spt_copyenv at setproctitle.c:94
 #2 spt_init at setproctitle.c:172
 #3 call_init at dl-init.c:82
 #4 _dl_init at dl-init.c:131
 #5 dl_open_worker at dl-open.c:566
 #6 _dl_catch_error at dl-error.c:177
 #7 _dl_open at dl-open.c:656
 #8 dlopen_doit at dlopen.c:66
 #9 _dl_catch_error at dl-error.c:177

Comment 1 Colin J Thomson 2013-06-06 20:17:37 UTC
Created attachment 757871 [details]
File: backtrace

Comment 2 Colin J Thomson 2013-06-06 20:17:41 UTC
Created attachment 757872 [details]
File: cgroup

Comment 3 Colin J Thomson 2013-06-06 20:17:46 UTC
Created attachment 757873 [details]
File: core_backtrace

Comment 4 Colin J Thomson 2013-06-06 20:17:50 UTC
Created attachment 757874 [details]
File: dso_list

Comment 5 Colin J Thomson 2013-06-06 20:17:54 UTC
Created attachment 757875 [details]
File: environ

Comment 6 Colin J Thomson 2013-06-06 20:17:58 UTC
Created attachment 757876 [details]
File: limits

Comment 7 Colin J Thomson 2013-06-06 20:18:04 UTC
Created attachment 757877 [details]
File: maps

Comment 8 Colin J Thomson 2013-06-06 20:18:08 UTC
Created attachment 757878 [details]
File: open_fds

Comment 9 Colin J Thomson 2013-06-06 20:18:11 UTC
Created attachment 757879 [details]
File: proc_pid_status

Comment 10 Colin J Thomson 2013-06-06 20:18:15 UTC
Created attachment 757880 [details]
File: var_log_messages

Comment 11 Kevin Kofler 2013-06-07 20:30:19 UTC
*** Bug 971751 has been marked as a duplicate of this bug. ***

Comment 12 Colin J Thomson 2013-06-12 21:50:17 UTC
It looks like a recent update has now fixed this, maybe it was the update of Samba a few days ago from updates-testing. I cannot reproduce this crash now.


Note You need to log in before you can comment on or make changes to this bug.