Bug 971597 - Docs don't specify what browsers Beaker supports
Docs don't specify what browsers Beaker supports
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: Doc (Show other bugs)
0.12
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.15
: ---
Assigned To: Nick Coghlan
tools-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 17:27 EDT by Raymond Mancy
Modified: 2014-12-07 20:15 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 22:29:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2013-06-06 17:27:26 EDT
Description of problem:

We do not make a note of what browser Beaker officially supports

Version-Release number of selected component (if applicable):

0.12

How reproducible:

Always

Steps to Reproduce:
1. Try to find out what browser Beaker supports
2.
3.

Actual results:

Can't find it

Expected results:

Should be able to

Additional info:

We don't expect to find many oddities with how the Beaker UI looks/works between different browsers, but they are probably out there. We should publicly define what browsers we support (or at least what we test on, and thus what we expect should work), so people having a problem can be sure its a genuine bug, and not an oddity of their particular browser.
Comment 2 Nick Coghlan 2013-09-25 02:11:52 EDT
Since 0.15 starts making additional demands on the browser's JS and CSS support, we should get this documented for the final release.
Comment 3 Nick Coghlan 2013-09-27 00:20:56 EDT
On Gerrit: http://gerrit.beaker-project.org/#/c/2300/

Also notes the supported platforms for the command line client
Comment 5 wangjing 2013-09-27 06:01:40 EDT
verified on beaker-devel Version 0.15.0rc2(20130927)-->pass

Steps:
1. visit:
http://beaker-project.org/docs-release-0.15/user-guide/interface.html
http://beaker-project.org/docs-release-0.15/user-guide/bkr-client.html
2. check the docs that notes what browsers Beaker supports and the supported platforms for the command line client


Actual results:
same as expected results.

Expected results:
should notes what browsers Beaker supports and the supported platforms for the command line client
Comment 6 Nick Coghlan 2013-10-02 22:29:51 EDT
Beaker 0.15 has been released.

Note You need to log in before you can comment on or make changes to this bug.