Bug 9716 - startx fails due to relative leading path in /etc/X11/X
startx fails due to relative leading path in /etc/X11/X
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinitrc (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-23 10:29 EST by corth
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 14:50:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description corth 2000-02-23 10:29:51 EST
pwd shows my home area as:

/.automount/myhost/root/users/corth

since I mount this area from machine "myhost".

When I startx, I get errors like:

/.automount/myhost/root/usr/X11R6/Xsun not found

Removing the leading "../../" in the exec statement in /etc/X11/X fixes
this problem.
Comment 1 Preston Brown 2000-02-23 14:50:59 EST
fixed for final release.

Note You need to log in before you can comment on or make changes to this bug.