Bug 971644 - [RFE]Non-admin account could add system-member on group page.
[RFE]Non-admin account could add system-member on group page.
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.12
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 22:58 EDT by xjia
Modified: 2016-07-03 21:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-03 21:13:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xjia 2013-06-06 22:58:54 EDT
Description of problem:
Non-admin account create a group, but now he doesn't have any machine. Now admin account change one system's owner to him. And non-admin account still can't add machine on group page.

Version-Release number of selected component (if applicable):
0.12

How reproducible:
always

Steps to Reproduce:
1.Non-admin account creates a group.
2.Admin account changes one system's owner to the user (step 1)
3.Non-admin still can't add system-member to this group on group page

Actual results:
Can't add it because of no "Add" button on group page

Expected results:
Should add it successfully. 

Additional info:
Comment 1 Nick Coghlan 2013-06-06 23:07:48 EDT
Just noting explicitly that the system owner *can* add the system to the group from the group tab on the system page.
Comment 4 Dan Callaghan 2016-07-03 21:13:24 EDT
No longer relevant now that groups don't contain systems anymore. This case works fine for the newer pools UI.

Note You need to log in before you can comment on or make changes to this bug.