Bug 97165 - gcc 3.3-5 misleading warning with -fno-rtti
Summary: gcc 3.3-5 misleading warning with -fno-rtti
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-11 03:12 UTC by Valdis Kletnieks
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version: 3.3-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-17 16:45:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Valdis Kletnieks 2003-06-11 03:12:01 UTC
Description of problem:
gcc issues misleading warning for -fno-rtti

Version-Release number of selected component (if applicable):
gcc-3.3-5

How reproducible:
Compile a C program with -fno-rtti

Steps to Reproduce:
1. 
2.
3.
    
Actual results:
Error message about using -frtti is issued

Expected results:
Either issue message about -fno-rtti, or issue no message since we
said -f*NO*-rtti.

Additional info:

[~]2 cat hello.c
main() {printf("Hellos world!\n");}
[~]2 cc -fno-rtti -o hello hello.c
cc1: warning: "-frtti" is valid for C++ but not for C/ObjC
[~]2 cc --version
cc (GCC) 3.3 20030604 (Red Hat Linux 3.3-5)
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


Note You need to log in before you can comment on or make changes to this bug.