Bug 971680 - glusterd : after rebooting RHS server, bricks came online but status is showing 'N/A' in port number column for those bricks
glusterd : after rebooting RHS server, bricks came online but status is showi...
Status: CLOSED DUPLICATE of bug 865396
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
Matt Zywusko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 02:49 EDT by Rachana Patel
Modified: 2015-11-03 18:05 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-20 02:02:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-06-07 02:49:39 EDT
Description of problem:
glusterd : after rebooting RHS server, bricks came online but status is showing 'N/A' in port number column for those bricks

Version-Release number of selected component (if applicable):
3.4.0.9rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. had a cluster of 4 server and 3 volumes. rebooted one server.
2.when it came up checked volume status and peer status

[root@mia ~]# gluster peer status
Number of Peers: 3

Hostname: 10.70.34.116
Uuid: c5154da1-be15-40e2-b5f3-9be6dadafd43
State: Peer in Cluster (Connected)

Hostname: fred.lab.eng.blr.redhat.com
Uuid: 292b158a-7650-4e09-9bc0-71e392f0d0c1
State: Peer in Cluster (Connected)

Hostname: fan.lab.eng.blr.redhat.com
Uuid: a37ff566-da82-4ae4-90c6-17763466fd36
State: Peer in Cluster (Connected)


[root@mia ~]# gluster v status 
Status of volume: test1
Gluster process						Port	Online	Pid
------------------------------------------------------------------------------
Brick fred.lab.eng.blr.redhat.com:/rhs/brick1/t1	49154	Y	32380
Brick mia.lab.eng.blr.redhat.com:/rhs/brick1/t1		N/A	Y	1871
Brick cutlass.lab.eng.blr.redhat.com:/rhs/brick1/t1	49154	Y	8989
NFS Server on localhost					2049	Y	1957
NFS Server on 292b158a-7650-4e09-9bc0-71e392f0d0c1	2049	Y	3310
NFS Server on c5154da1-be15-40e2-b5f3-9be6dadafd43	2049	Y	11535
NFS Server on a37ff566-da82-4ae4-90c6-17763466fd36	2049	Y	1838
 
There are no active volume tasks
Status of volume: Tfile
Gluster process						Port	Online	Pid
------------------------------------------------------------------------------
Brick fred.lab.eng.blr.redhat.com:/rhs/brick1/l		49153	Y	2688
Brick mia.lab.eng.blr.redhat.com:/rhs/brick1/l		N/A	Y	1861
Brick cutlass.lab.eng.blr.redhat.com:/rhs/brick1/l	49153	Y	10309
NFS Server on localhost					2049	Y	1957
NFS Server on a37ff566-da82-4ae4-90c6-17763466fd36	2049	Y	1838
NFS Server on 292b158a-7650-4e09-9bc0-71e392f0d0c1	2049	Y	3310
NFS Server on c5154da1-be15-40e2-b5f3-9be6dadafd43	2049	Y	11535
 
There are no active volume tasks
Status of volume: again
Gluster process						Port	Online	Pid
------------------------------------------------------------------------------
Brick fred.lab.eng.blr.redhat.com:/rhs/brick1/a2	49155	Y	24524
Brick mia.lab.eng.blr.redhat.com:/rhs/brick1/a2		N/A	Y	1865
Brick cutlass.lab.eng.blr.redhat.com:/rhs/brick1/a2	49155	Y	11525
Brick fan.lab.eng.blr.redhat.com:/rhs/brick1/a2		49152	Y	1830
NFS Server on localhost					2049	Y	1957
NFS Server on 292b158a-7650-4e09-9bc0-71e392f0d0c1	2049	Y	3310
NFS Server on c5154da1-be15-40e2-b5f3-9be6dadafd43	2049	Y	11535
NFS Server on a37ff566-da82-4ae4-90c6-17763466fd36	2049	Y	1838
 
There are no active volume tasks

[root@mia ~]# cat /var/lib/glusterd/vols/again/bricks/mia.lab.eng.blr.redhat.com\:-rhs-brick1-a2 
hostname=mia.lab.eng.blr.redhat.com
path=/rhs/brick1/a2
listen-port=0
rdma.listen-port=0
decommissioned=0


[root@mia ~]# ps -ef | grep 1865
root      1865     1  0 21:45 ?        00:00:00 /usr/sbin/glusterfsd -s mia.lab.eng.blr.redhat.com --volfile-id again.mia.lab.eng.blr.redhat.com.rhs-brick1-a2 -p /var/lib/glusterd/vols/again/run/mia.lab.eng.blr.redhat.com-rhs-brick1-a2.pid -S /var/run/57ad5ec9be719ba71c7ea5048c9868b5.socket --brick-name /rhs/brick1/a2 -l /var/log/glusterfs/bricks/rhs-brick1-a2.log --xlator-option *-posix.glusterd-uuid=8675332f-f033-4800-aa2c-9291fc868fbf --brick-port 49154 --xlator-option again-server.listen-port=49154
root      4373  3227  0 23:11 pts/0    00:00:00 grep 1865



Actual results:
bricks came online but status is showing 'N/A' in port number column for those bricks
Comment 3 Atin Mukherjee 2015-04-02 00:18:38 EDT
We have seen this issue is been fixed in 3.0.4. Its a duplicate of #BZ 865396
Can be verified once the branching takes place.

Note You need to log in before you can comment on or make changes to this bug.