Bug 971696 - quota: size field does not take in consideration about size occupied
quota: size field does not take in consideration about size occupied
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: vpshastry
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 03:27 EDT by Saurabh
Modified: 2016-01-19 01:11 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-06-07 03:27:05 EDT
Description of problem:
even after creating the data inside the volume,
the size field displays "0Bytes"

Version-Release number of selected component (if applicable):
[root@rhsauto033 ~]# rpm -qa | grep glusterfs
glusterfs-3.4rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4rhs-1.el6rhs.x86_64
glusterfs-geo-replication-3.4rhs-1.el6rhs.x86_64
glusterfs-server-3.4rhs-1.el6rhs.x86_64


How reproducible:
always

Steps to Reproduce:
1. create a volume of 6x2 type, start it.
2. enable quota
3. gluster volume quota <volume-name> limit-usage / 1GB
4. mount the volume using nfs or fuse, create files inside the mount-point
5. gluster volume quota <volume-name> list

Actual results:
[root@rhsauto033 ~]# gluster volume quota dist-rep list
	path		  limit_set (soft/hard)		     size
----------------------------------------------------------------------------------
/                                      1GB/90%               0Bytes


if you look into one of the bricks, the data is there

[root@rhsauto033 ~]# ls -l /rhs/brick1/d1
total 400
-rw-r--r--. 2 root root 102400 Jun  6 03:26 f.2
-rw-r--r--. 2 root root 102400 Jun  6 03:26 f.3
-rw-r--r--. 2 root root 102400 Jun  6 03:26 f.7
-rw-r--r--. 2 root root 102400 Jun  6 03:26 f.9


Expected results:
altogether the size field is not getting updated with required information

Additional info:
Comment 3 Scott Haines 2013-09-23 18:39:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 4 Scott Haines 2013-09-23 18:43:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.