Bug 9717 - cdda2wav -D /dev/cdrom -O au fails
Summary: cdda2wav -D /dev/cdrom -O au fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: sparc Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-23 15:34 UTC by Brock Organ
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-02 21:51:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brock Organ 2000-02-23 15:34:23 UTC
[root@ultra1 /root]# cdda2wav -D /dev/cdrom -t2 -O au 2>&1 | tee
cdda2wav.1.log

cdrom device (/dev/cdrom) is not of type generic SCSI. Setting interface to
cooked_ioctl.
729088 bytes buffer memory requested, 4 buffers, 75 sectors
#Cdda2wav version 1.8_linux_2.2.14-1.3.0_sparc_sparc real time sched.
soundcard support
<... lots of repetitive stuff deleted ...>
 1/ 1/ 1/   5304  96%
 1/ 1/ 1/  87624 100%cdda2wav: ringbuff.c:120: drop_buffer: Assertion
`(total_buffers - ((*total_segments_read) -
(*total_segments_written))) < total_buffers' failed.
Child exited due to signal 6

Comment 1 Bill Nottingham 2000-02-23 22:03:59 UTC
Looks like it had broken support for IDE non-CDDA drives.
Fixed in 1.8-2.

Comment 2 Brock Organ 2000-03-03 16:53:59 UTC
it is still not resolved fully in 1.8-2:

[root@ultra1 /root]# rpm -q cdda2wav
cdda2wav-1.8-2
[root@ultra1 /root]#

[root@ultra1 /root]# cdda2wav -D /dev/cdrom -O au -t2
cdrom device (/dev/cdrom) is not of type generic SCSI. Setting interface to
cooked_ioctl.
729088 bytes buffer memory requested, 4 buffers, 75 sectors
#Cdda2wav version 1.8_linux_2.2.14-1.1.0_sparc_sparc real time sched. soundcard
support

<... stuff removed ...>

samplefile size will be 41759792 bytes.
recording 236.07333 seconds stereo with 16 bits @ 44100.0 Hz ->'audio'...
overlap:min/max/cur, jitter, percent_done:
 1/ 7/ 1/   2352  99%cooked: Read cdda : Cannot allocate memory
 sector 18488 + 4294967290, buffer 70142000 + b2000
request defined buff:: Invalid argument
parent writer sem request failed
cdda2wav: ringbuff.c:120: drop_buffer: Assertion `(total_buffers -
((*total_segments_read) - (*total_segments_written))) < total_buffers' failed.
Floating point exception (core dumped)
[root@ultra1 /root]#

Comment 3 Cristian Gafton 2000-03-06 21:07:59 UTC
Guys, please help with this one.

Comment 4 Derek Tattersall 2000-03-13 15:40:59 UTC
this error only occurs on one in-house machine (ultra1.test) and does not occur
on its twin (ultra2.test) ... without additional information, it appears machine
specific and may be flaky hardware ...

Comment 5 Trond Eivind Glomsrxd 2000-05-02 21:51:59 UTC
Probably flaky hardware.


Note You need to log in before you can comment on or make changes to this bug.