Bug 97171 - wrong sequence in the instructions of release notes about add new fonts
wrong sequence in the instructions of release notes about add new fonts
Status: CLOSED DUPLICATE of bug 90154
Product: Red Hat Linux
Classification: Retired
Component: redhat-release (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
http://www.redhat.com/docs/manuals/li...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 02:46 EDT by vivian_huang
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vivian_huang 2003-06-11 02:46:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.2.1) Gecko/20030225

Description of problem:
Please follow this link :
http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/release-notes/x86/

And see below:
"
1. Create the /usr/share/fonts/local/  directory (if it doesn't already exist):

mkdir /usr/share/fonts/local/

If you had to create /usr/share/fonts/local/, you must then add it to the X font
server (xfs) path:

chkfontpath --add /usr/share/fonts/local/

2. Copy the new font file into /usr/share/fonts/local/
"

We failed on it when we try to add new fonts step by step following this
instruction like this:
1) First we create the directory:
mkdir /usr/share/fonts/local/

2)Follow the instructions to add the path to the X font server (xfs) path.
chkfontpath --add /usr/share/fonts/local/

Then get this error message:
chkfontpath:error opening /usr/share/fonts/local/fonts.dir, unwilling to add path 


At last we fount that we should first create the fonts.dir and fonts.scale
files. after creat these two files, and also copy the new fonts files to that
exatcly directory. then we can add the new fonts succesfully.

So the sequence of that instructions offered by the Red Hat 9.0 release notes is
indeed incorrect. And there should be some steps too to create the fonts.dir and
fonts.scale files to that directory too.







Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

    1. Create the /usr/share/fonts/local/  directory (if it doesn't already exist):

mkdir /usr/share/fonts/local/

If you had to create /usr/share/fonts/local/, you must then add it to the X font
server (xfs) path:

chkfontpath --add /usr/share/fonts/local/

2. Copy the new font file into /usr/share/fonts/local/

3. Update the font information by issuing the following command:

ttmkfdir -d /usr/share/fonts/local/ -o /usr/share/fonts/local/fonts.scale

4. Reload the xfs font server using the following command:

service xfs reload

Actual Results:  get error messages:

chkfontpath:error opening /usr/share/fonts/local/fonts.dir, unwilling to add path 

Additional info:
Comment 1 Ed Bailey 2003-06-11 09:50:41 EDT

*** This bug has been marked as a duplicate of 90154 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.