Bug 971745 - Packstack should show example option formats or values in prompts.
Packstack should show example option formats or values in prompts.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
x86_64 Linux
low Severity low
: z1
: 4.0
Assigned To: Ivan Chavero
Nir Magnezi
: ZStream
: 977955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 04:23 EDT by Jaroslav Henner
Modified: 2016-04-26 09:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.21.dev948.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 09:23:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 56796 None None None Never
OpenStack gerrit 62974 None None None Never

  None (edit)
Description Jaroslav Henner 2013-06-07 04:23:39 EDT
Description of problem:
Packstack should be more descriptive about it's inputs:

# A comma separated list of VLAN ranges for the Quantum linuxbridge
# plugin
CONFIG_QUANTUM_LB_VLAN_RANGES=

what is the VLAN range format? 10-50 or 10:50 ?


# A comma separated list of interface mappings for the Quantum
# linuxbridge plugin
CONFIG_QUANTUM_LB_INTERFACE_MAPPINGS=

physnet1:eth1 or host1:physnet1:eth1, host2:physnet1:eth1


# Type of network to allocate for tenant networks
CONFIG_QUANTUM_LB_TENANT_NETWORK_TYPE=local

I would at least showed vlan, local


Same should be done for OVS

Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.10.dev605.el6ost.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Alvaro Lopez Ortega 2013-11-13 14:04:40 EST
*** Bug 977955 has been marked as a duplicate of this bug. ***
Comment 3 Alvaro Lopez Ortega 2013-11-18 08:26:29 EST
Merged. Moving to MODIFIED.
Comment 5 Scott Lewis 2013-11-19 11:54:32 EST
Auto adding >= MODIFIED bugs to beta
Comment 8 Nir Magnezi 2013-12-18 07:18:14 EST
Tested NVR: openstack-packstack-2013.2.1-0.20.dev936.el6ost.noarch

generated a packstack answer file.

(In reply to Jaroslav Henner from comment #0)
> Description of problem:
> Packstack should be more descriptive about it's inputs:
> 
> # A comma separated list of VLAN ranges for the Quantum linuxbridge
> # plugin
> CONFIG_QUANTUM_LB_VLAN_RANGES=
> 
> what is the VLAN range format? 10-50 or 10:50 ?
> 

snipped from the newly generated packstack answer file:
# A comma separated list of VLAN ranges for the Neutron linuxbridge
# plugin (eg. physnet1:1:4094,physnet2,physnet3:3000:3999)
CONFIG_NEUTRON_LB_VLAN_RANGES=

> 
> # A comma separated list of interface mappings for the Quantum
> # linuxbridge plugin
> CONFIG_QUANTUM_LB_INTERFACE_MAPPINGS=
> 
> physnet1:eth1 or host1:physnet1:eth1, host2:physnet1:eth1
> 

snipped from the newly generated packstack answer file:
# A comma separated list of interface mappings for the Neutron
# linuxbridge plugin (eg. physnet1:br-eth1,physnet2:br-eth2,physnet3
# :br-eth3)
CONFIG_NEUTRON_LB_INTERFACE_MAPPINGS=

> 
> # Type of network to allocate for tenant networks
> CONFIG_QUANTUM_LB_TENANT_NETWORK_TYPE=local
> 
> I would at least showed vlan, local
> 
snipped from the newly generated packstack answer file:
# The type of network to allocate for tenant networks (eg. vlan,
# local, gre)
CONFIG_NEUTRON_LB_TENANT_NETWORK_TYPE=local

> 
> Same should be done for OVS
> 
snipped from the newly generated packstack answer file:
# Type of network to allocate for tenant networks (eg. vlan, local,
# gre)
CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=local

# A comma separated list of VLAN ranges for the Neutron openvswitch
# plugin (eg. physnet1:1:4094,physnet2,physnet3:3000:3999)
CONFIG_NEUTRON_OVS_VLAN_RANGES=

# A comma separated list of bridge mappings for the Neutron
# openvswitch plugin (eg. physnet1:br-eth1,physnet2:br-eth2,physnet3
# :br-eth3)
CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=

# A comma separated list of colon-separated OVS bridge:interface
# pairs. The interface will be added to the associated bridge.
CONFIG_NEUTRON_OVS_BRIDGE_IFACES=


The following parameters should be more descriptive about their inputs as well:

# A comma separated list of tunnel ranges for the Neutron openvswitch
# plugin
CONFIG_NEUTRON_OVS_TUNNEL_RANGES=

# Override the IP used for GRE tunnels on this hypervisor to the IP
# found on the specified interface (defaults to the HOST IP)
CONFIG_NEUTRON_OVS_TUNNEL_IF=
Comment 10 Ivan Chavero 2013-12-18 15:38:39 EST
Fixed on this review: https://review.openstack.org/#/c/62974/
Comment 11 Alvaro Lopez Ortega 2013-12-18 16:05:39 EST
Patch reviewed and merged.
Comment 15 Nir Magnezi 2014-01-15 07:44:41 EST
Verified NVR: openstack-packstack-2013.2.1-0.22.dev956.el6ost.noarch


Following to Comment #8, Verified the descriptions of CONFIG_NEUTRON_OVS_TUNNEL_RANGES and CONFIG_NEUTRON_OVS_TUNNEL_IF

Result:
=======
# A comma separated list of tunnel ranges for the Neutron openvswitch
# plugin (eg. 1:1000)
CONFIG_NEUTRON_OVS_TUNNEL_RANGES=

# The interface for the OVS tunnel. Packstack will override the IP
# address used for GRE tunnels on this hypervisor to the IP found on
# the specified interface. (eg. eth1)
CONFIG_NEUTRON_OVS_TUNNEL_IF=
Comment 17 Ivan Chavero 2014-01-17 18:35:13 EST
doc text set to "-"
Comment 20 Lon Hohberger 2014-02-04 12:20:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-0046.html

Note You need to log in before you can comment on or make changes to this bug.