Bug 971754 - [site-changes-integration] The login link in blog or forums page is not correct.
[site-changes-integration] The login link in blog or forums page is not correct.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
: 973158 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 04:33 EDT by Wei Sun
Modified: 2015-05-14 21:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:52:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
login (30.54 KB, image/png)
2013-06-07 05:57 EDT, Wei Sun
no flags Details

  None (edit)
Description Wei Sun 2013-06-07 04:33:32 EDT
Description of problem:
Access any blog in /blogs page,and click the login (please refer to attachment).But login link(/user/login?destination=node%2F14509%23comment-form) is not correct,should be correct (user/?destination=node%2F14509%23comment-form)

Version-Release number of selected component (if applicable):
STG(devenv-stage_364)

How reproducible:
Always

Steps to Reproduce:
1.Access any blog in /blogs page
2.Click the login 
3.

Actual results:
The login link is not correct

Expected results:
The login link should be correct

Additional info:
Comment 1 Yujie Zhang 2013-06-07 04:36:34 EDT
The issue happens on all parts like blog or forum part, the url should better be https://www.stg.openshift.com/user?destination=node%2F14479%23comment-form
Comment 2 Wei Sun 2013-06-07 05:57:34 EDT
Created attachment 758087 [details]
login
Comment 3 Clayton Coleman 2013-06-07 10:20:58 EDT
Low since the URL still works and won't block users.  Both forms are acceptable, agree /user is superior.
Comment 4 Clayton Coleman 2013-06-12 17:09:27 EDT
The URL does not actually work, which causes login failures.
Comment 5 Clayton Coleman 2013-06-12 17:09:47 EDT
*** Bug 973158 has been marked as a duplicate of this bug. ***
Comment 6 Fabiano Franz 2013-06-12 23:11:14 EDT
Pull request placed:

https://github.com/openshift/li/pull/1622
Comment 7 openshift-github-bot 2013-06-13 10:38:22 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/9054671c287c4094f50977190cd22e1817aec084
Bug 971754: must forward the destination parameter when redirecting user/login to user
Comment 8 Yujie Zhang 2013-06-14 01:08:02 EDT
Tested on devenv_3360, the login link on blog and forum links can work correctly now, so verify this bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.